summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/shed/shed-1.15.ebuild')
-rw-r--r--app-editors/shed/shed-1.15.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/app-editors/shed/shed-1.15.ebuild b/app-editors/shed/shed-1.15.ebuild
index a0f12ddc4a64..5c8bc3d79a8c 100644
--- a/app-editors/shed/shed-1.15.ebuild
+++ b/app-editors/shed/shed-1.15.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/shed-1.15.ebuild,v 1.3 2012/08/22 00:19:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/shed/shed-1.15.ebuild,v 1.4 2014/10/26 10:39:47 jer Exp $
-EAPI="4"
-
-inherit eutils
+EAPI=5
+inherit autotools eutils
DESCRIPTION="Simple Hex EDitor"
HOMEPAGE="http://shed.sourceforge.net/"
@@ -13,15 +12,17 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
RDEPEND="sys-libs/ncurses"
-DPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
- epatch "${FILESDIR}"/${P}-interix.patch
-}
-
-src_compile() {
- emake AM_CFLAGS="${CFLAGS}"
+ epatch \
+ "${FILESDIR}"/${P}-cflags.patch \
+ "${FILESDIR}"/${P}-interix.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
}