summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/setnu/setnu-1.06.ebuild')
-rw-r--r--app-emacs/setnu/setnu-1.06.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/setnu/setnu-1.06.ebuild b/app-emacs/setnu/setnu-1.06.ebuild
new file mode 100644
index 000000000000..5190910f6814
--- /dev/null
+++ b/app-emacs/setnu/setnu-1.06.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/setnu/setnu-1.06.ebuild,v 1.1 2004/11/16 02:42:28 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Display line numbers in Emacs buffers"
+HOMEPAGE="http://www.wonderworks.com/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/emacs"
+
+SITEFILE=50setnu-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}