summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild')
-rw-r--r--app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild b/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
index aae37dbc6a32..a0c4b84c1727 100644
--- a/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
+++ b/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild,v 1.5 2004/08/30 15:01:28 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild,v 1.6 2004/08/30 15:16:09 lv Exp $
DESCRIPTION="GNU C Library for emulation of 32bit x86 on amd64"
HOMEPAGE="http://www.gentoo.org/"
@@ -46,3 +46,17 @@ run_verbose() {
$@ || die "unable to $@"
}
+pkg_postinst() {
+ # for some reason we have users with lib32 as a directory and not a symlink.
+ # my guess is a broken version of opengl-update somewhere... but since
+ # having lib32 as a directory is definately broken, lets fix that here.
+ if [ ! -L /usr/lib32 ] ; then
+ ewarn "/usr/lib32 is not a symlink... fixing"
+ run_verbose mv /usr/lib32 /usr/lib32-bork-bork-bork
+ run_verbose ln -sf /emul/linux/x86/usr/lib /usr/lib32
+ echo "moving /usr/lib32-bork-bork-bork/* to /usr/lib32/"
+ mv -v /usr/lib32-bork-bork-bork/* /usr/lib32/
+ run_verbose rm -rf /usr/lib32-bork-bork-bork
+ einfo "fixed!"
+ fi
+}