summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild')
-rw-r--r--app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild b/app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild
new file mode 100644
index 000000000000..dfcb58a9af32
--- /dev/null
+++ b/app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce-sync-engine/synce-sync-engine-0.12.ebuild,v 1.1 2008/11/13 16:31:01 mescalinum Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="SynCE - Synchronization engine"
+HOMEPAGE="http://sourceforge.net/projects/synce/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-python/pygobject
+ dev-python/dbus-python
+ >=app-pda/libopensync-plugin-python-0.22
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/pyxml
+ ~app-pda/synce-librra-0.12
+ ~app-pda/synce-librtfcomp-1.1"
+
+SRC_URI="mirror://sourceforge/synce/sync-engine-${PV}.tar.gz"
+S=${WORKDIR}/sync-engine-${PV}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGELOG COPYING"
+
+ insinto /usr/share/${PN}/
+ doins config/syncengine.conf.xml
+
+ insinto /usr/share/dbus-1/services/
+ doins config/org.synce.SyncEngine.service
+
+ distutils_src_install
+
+ # TODO - move this to separate ebuilds.
+ if has_version '>=app-pda/libopensync-0.30'; then
+ insinto /usr/lib/opensync-1.0/python-plugins
+ newins plugins/synce-opensync-plugin-3x.py synce-opensync-plugin.py
+ else
+ insinto /usr/lib/opensync/python-plugins
+ newins plugins/synce-opensync-plugin-2x.py synce-opensync-plugin.py
+ fi
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "IMPORTANT - If you are upgrading from a version earlier than 19-12-2007"
+ ewarn "(earlier than 0.11), please delete the contents of your ~/.synce directory"
+ ewarn "including the partnerships subdirectory, but KEEP config.xml. Then recreate"
+ ewarn "your partnerships. Please see the CHANGELOG for more info."
+ ewarn ""
+ ewarn "config.xml has been renamed to syncengine.conf.xml"
+ ewarn ""
+
+ einfo "A default configuration file has been installed into"
+ einfo "/usr/share/${PN}/syncengine.conf.xml The default search path for this file"
+ einfo "is /etc/ then ~/.synce/ You may customise it by copying it to either of"
+ einfo "those locations. Note you will have to manually migrate your old config.xml"
+}