summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci/glpk/glpk-4.2.ebuild')
-rw-r--r--app-sci/glpk/glpk-4.2.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/app-sci/glpk/glpk-4.2.ebuild b/app-sci/glpk/glpk-4.2.ebuild
index 6fa23a4f4da1..deaa388b6f4e 100644
--- a/app-sci/glpk/glpk-4.2.ebuild
+++ b/app-sci/glpk/glpk-4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/glpk/glpk-4.2.ebuild,v 1.2 2003/12/09 18:10:46 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/glpk/glpk-4.2.ebuild,v 1.3 2004/04/19 10:15:48 phosphan Exp $
DESCRIPTION="GNU Linear Programming Kit"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
@@ -9,18 +9,27 @@ HOMEPAGE="http://www.gnu.org/software/${PN}/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="java doc"
RDEPEND="java? ( >=virtual/jdk-1.4* )
sys-libs/glibc"
DEPEND=">=sys-devel/gcc-3.2* ${RDEPEND}
doc? ( virtual/ghostscript )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:/usr/local/lib:${S}/src:g" -i contrib/jni/c/Makefile \
+ || die "sed failed correcting library path"
+}
+
src_compile() {
LIBS="${LIBS} -lm" econf --enable-shared || die
emake || die "emake failed"
if use java; then
cd ${S}/contrib/jni
- emake || die "emake java failed"
+ local extrainclude="-I ${S}/contrib/jni/java -I ${S}/include"
+ emake CFLAGS="${CFLAGS} ${extrainclude}" || die "emake java failed"
fi
}
@@ -30,7 +39,7 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
#examples
docinto examples
- rm ${S}/examples/{Make*,glpsol*}
+
dodoc ${S}/examples/*
#docs
if use doc; then