summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/nqc/nqc-3.1_p6.ebuild')
-rw-r--r--dev-lang/nqc/nqc-3.1_p6.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/dev-lang/nqc/nqc-3.1_p6.ebuild b/dev-lang/nqc/nqc-3.1_p6.ebuild
index 8ec4074d0c5f..07057190cdd4 100644
--- a/dev-lang/nqc/nqc-3.1_p6.ebuild
+++ b/dev-lang/nqc/nqc-3.1_p6.ebuild
@@ -1,29 +1,31 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/nqc-3.1_p6.ebuild,v 1.3 2011/01/10 15:59:24 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqc/nqc-3.1_p6.ebuild,v 1.4 2012/07/04 19:46:56 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils toolchain-funcs
DESCRIPTION="Not Quite C - C-like compiler for Lego Mindstorms"
-SRC_URI="http://bricxcc.sourceforge.net/nqc/release/${P/_p/.r}.tgz"
HOMEPAGE="http://bricxcc.sourceforge.net/nqc/"
+SRC_URI="http://bricxcc.sourceforge.net/nqc/release/${P/_p/.r}.tgz"
-S="${WORKDIR}/${P/_p/.r}"
-
-SLOT="0"
LICENSE="MPL-1.0"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="usb"
DEPEND="usb? ( dev-libs/legousbtower )"
RDEPEND="${DEPEND}"
+S="${WORKDIR}"
+
src_prepare() {
- sed -i Makefile \
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ sed \
-e 's|$(CXX) -o |$(CXX) $(LDFLAGS) -o |g' \
-e 's|/usr/local|/usr|' \
+ -i Makefile \
|| die "sed Makefile"
}
@@ -34,13 +36,12 @@ src_configure() {
}
src_compile() {
- emake CXX=$(tc-getCXX) LDFLAGS="${LDFLAGS}" || die "emake"
+ emake CXX=$(tc-getCXX) LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin bin/*
- mv nqc-man-2.1r1-0.man nqc.1
- doman nqc.1
+ newman nqc-man-2.1r1-0.man nqc.1
dodoc history.txt readme.txt scout.txt test.nqc
}
@@ -49,11 +50,11 @@ pkg_postinst() {
elog "the environment variable RCX_PORT or use the nqc command line"
elog "option -S to specify your serial port."
if use usb; then
- elog
+ echo
elog "You have enabled USB support. To use usb on the"
elog "command line use the -Susb command line option"
else
- elog
+ echo
elog "You have not enabled usb support and will be unable"
elog "to use the usb IR tower. To enable USB use the usb use flag"
fi