summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdnet/libdnet-1.11.ebuild')
-rw-r--r--dev-libs/libdnet/libdnet-1.11.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libdnet/libdnet-1.11.ebuild b/dev-libs/libdnet/libdnet-1.11.ebuild
new file mode 100644
index 000000000000..a1973b7a761e
--- /dev/null
+++ b/dev-libs/libdnet/libdnet-1.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.11.ebuild,v 1.1 2006/07/23 21:32:11 vanquirius Exp $
+
+inherit eutils
+
+DESCRIPTION="simplified, portable interface to several low-level networking routines"
+HOMEPAGE="http://libdnet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libdnet/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="python"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's/suite_free(s);//' test/check/*.c || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-1.10-gcc4.diff
+}
+
+src_compile () {
+ econf $(use_with python) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ einfo "self test fails with permission problems"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}