summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild')
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild
new file mode 100644
index 000000000000..b4350262bc46
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.0.3.ebuild,v 1.1 2010/06/17 13:21:34 mabi Exp $
+
+EAPI="2"
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php/PEAR-PEAR-1.8.1"
+PDEPEND="dev-php/pear"
+HOMEPAGE="http://pear.php.net/package/Structures_Graph"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+
+ dohtml -r docs/html/*
+}