summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild')
-rw-r--r--dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild b/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild
new file mode 100644
index 000000000000..a909d8ba82f6
--- /dev/null
+++ b/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-sphinx/oslo-sphinx-2.5.0.ebuild,v 1.1 2015/03/25 18:29:52 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/}"
+
+DESCRIPTION="OpenStack Sphinx Extensions"
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# NOTE: dev-python/hacking is unecessary as there are no tests
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/requests-2.2.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"