summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip/sip-3.0.ebuild')
-rw-r--r--dev-python/sip/sip-3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sip/sip-3.0.ebuild b/dev-python/sip/sip-3.0.ebuild
new file mode 100644
index 000000000000..434a1469f284
--- /dev/null
+++ b/dev-python/sip/sip-3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-3.0.ebuild,v 1.1 2001/11/27 20:55:43 verwilst Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
+HOMEPAGE="http://www.thekompany.com/projects/pykde/"
+
+DEPEND="virtual/glibc
+ virtual/python"
+
+src_compile(){
+ ./configure --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING NEWS README THANKS TODO
+}