summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/ChangeLog7
-rw-r--r--dev-python/sip/files/digest-sip-4.21
-rw-r--r--dev-python/sip/sip-4.2.ebuild46
3 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 86d21f00795f..d1a1c45824fb 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sip
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.56 2005/02/08 05:06:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.57 2005/02/20 16:01:58 carlo Exp $
+
+*sip-4.2 (20 Feb 2005)
+
+ 20 Feb 2005; Carsten Lohrke <carlo@gentoo.org> +sip-4.2.ebuild:
+ version bump
07 Feb 2005; Jeremy Huddleston <eradicator@gentoo.org> sip-4.1.1.ebuild:
Multilib fix for python.
diff --git a/dev-python/sip/files/digest-sip-4.2 b/dev-python/sip/files/digest-sip-4.2
new file mode 100644
index 000000000000..264c5ad0e412
--- /dev/null
+++ b/dev-python/sip/files/digest-sip-4.2
@@ -0,0 +1 @@
+MD5 b884cc15228a166c9d6fc88aaaeccc96 sip-4.2.tar.gz 312926
diff --git a/dev-python/sip/sip-4.2.ebuild b/dev-python/sip/sip-4.2.ebuild
new file mode 100644
index 000000000000..3cfb23e1d947
--- /dev/null
+++ b/dev-python/sip/sip-4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.2.ebuild,v 1.1 2005/02/20 16:01:58 carlo Exp $
+
+inherit distutils
+
+MY_P=${P/"?.?.?_pre"/"snapshot-"}
+MY_P=${MY_P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/sip/${MY_P}.tar.gz"
+#SRC_URI="http://www.river-bank.demon.co.uk/download/snapshots/sip/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
+IUSE="debug doc"
+
+DEPEND="virtual/libc
+ x11-libs/qt
+ >=dev-lang/python-2.3"
+
+src_compile(){
+ distutils_python_version
+
+ local myconf="-l qt-mt -b /usr/bin -d /usr/$(get_libdir)/python${PYVER}/site-packages -e /usr/include/python${PYVER}"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc ChangeLog LICENSE NEWS README THANKS TODO
+ if use doc ; then dohtml doc/* ; fi
+}
+
+pkg_postinst() {
+ echo ""
+ einfo "Please note, that you have to emerge PyQt again, when upgrading from sip-3.x."
+ echo ""
+}