summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-lore/twisted-lore-0.1.0.ebuild')
-rw-r--r--dev-python/twisted-lore/twisted-lore-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild b/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild
new file mode 100644
index 000000000000..ce005c6683bf
--- /dev/null
+++ b/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted-lore/twisted-lore-0.1.0.ebuild,v 1.1 2005/04/08 14:35:49 lordvan Exp $
+
+inherit distutils
+
+# for alphas,..
+MY_PV="${PV/_alpha/a}"
+MY_PN="TwistedLore"
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="An NNTP protocol implementation with client and server(?)"
+HOMEPAGE="http://twistedmatrix.com/projects/lore/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Lore/0.1/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~alpha ~sparc"
+IUSE="doc"
+
+DEPEND=">=dev-python/twisted-2.0.0"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodir /usr/share/doc/${P}
+ cp -r ${S}/docs ${D}/usr/share/doc/${P}/
+ fi
+}