summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gambas/files/gambas-2.8.2-examples-Makefile-install.patch')
-rw-r--r--dev-util/gambas/files/gambas-2.8.2-examples-Makefile-install.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/gambas/files/gambas-2.8.2-examples-Makefile-install.patch b/dev-util/gambas/files/gambas-2.8.2-examples-Makefile-install.patch
new file mode 100644
index 000000000000..a7220f72e501
--- /dev/null
+++ b/dev-util/gambas/files/gambas-2.8.2-examples-Makefile-install.patch
@@ -0,0 +1,28 @@
+--- examples/Makefile.am.orig 2008-09-01
++++ examples/Makefile.am 2008-09-01
+@@ -19,11 +19,20 @@
+ @rm -rf $(DESTDIR)$(gbdatadir)/examples
+ @$(INSTALL) -d $(DESTDIR)$(gbdatadir)/examples
+ @cp -R $(srcdir)/examples $(DESTDIR)$(gbdatadir)
+- @(cd $(DESTDIR)$(gbdatadir)/examples; d=`pwd`; for p in */ */*/; do cd $$d/$$p; \
+- if test -e .project; then \
+- echo "Compiling $$p..."; cd $$d/$$p; $(DESTDIR)$(bindir)/gbc$(GAMBAS_VERSION) -ag -r $(DESTDIR)$(prefix); $(DESTDIR)$(bindir)/gba$(GAMBAS_VERSION); \
+- fi \
+- done)
++ @(cd $(DESTDIR)$(gbdatadir)/examples; d=`pwd`; \
++ for p in */ */*/; do \
++ cd $$d/$$p; \
++ if test -e .project; then \
++ echo "Compiling $$p..."; \
++ cd $$d/$$p; \
++ { \
++ $(DESTDIR)$(bindir)/gbc$(GAMBAS_VERSION) -ag -r $(DESTDIR)$(prefix) && \
++ $(DESTDIR)$(bindir)/gba$(GAMBAS_VERSION); \
++ } \
++ && rm -rf .gambas \
++ || { echo "Failed"; rm -rf .gambas *.gambas; } \
++ fi \
++ done)
+
+ uninstall-local:
+ @rm -rf $(DESTDIR)$(gbdatadir)/examples