summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kcheckpass/kcheckpass-4.4.3.ebuild')
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.4.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild b/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild
new file mode 100644
index 000000000000..31ba9936a841
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.4.3.ebuild,v 1.1 2010/05/03 20:24:25 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+DEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
+ "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}