summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdesu/kdesu-4.1.4.ebuild')
-rw-r--r--kde-base/kdesu/kdesu-4.1.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/kdesu/kdesu-4.1.4.ebuild b/kde-base/kdesu/kdesu-4.1.4.ebuild
new file mode 100644
index 000000000000..4c61c9806efc
--- /dev/null
+++ b/kde-base/kdesu/kdesu-4.1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesu/kdesu-4.1.4.ebuild,v 1.1 2009/01/13 21:52:19 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-runtime
+inherit kde4-meta
+
+# FIXME: Is default command ( su/sudo ) still configurable,
+# if not, USE-flag ?
+DESCRIPTION="KDE: gui for su(1)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug htmlhandbook"
+
+src_configure() {
+ # Upstream moved kdesu to libexec first, then decided to move it back
+ # to /${PREFIX}/bin/ , so I'm doing that now already.
+ sed -e '/kdesu_executable/s:LIBEXEC_INSTALL_DIR:BIN_INSTALL_DIR:' \
+ -i "${S}"/kdesu/kdesu/CMakeLists.txt || \
+ die "Moving kdesu from libexec to bin failed."
+
+ kde4-meta_src_configure
+}