summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/ksplash/ksplash-4.1.4.ebuild')
-rw-r--r--kde-base/ksplash/ksplash-4.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/ksplash/ksplash-4.1.4.ebuild b/kde-base/ksplash/ksplash-4.1.4.ebuild
new file mode 100644
index 000000000000..b62edd5ce800
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.1.4.ebuild,v 1.1 2009/01/13 22:50:38 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}