summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/solid/solid-4.4.1.ebuild')
-rw-r--r--kde-base/solid/solid-4.4.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-base/solid/solid-4.4.1.ebuild b/kde-base/solid/solid-4.4.1.ebuild
new file mode 100644
index 000000000000..2474c756e7ba
--- /dev/null
+++ b/kde-base/solid/solid-4.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.4.1.ebuild,v 1.1 2010/03/02 19:46:34 tampakrap Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}