summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/xparts/xparts-3.5.9.ebuild')
-rw-r--r--kde-base/xparts/xparts-3.5.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/xparts/xparts-3.5.9.ebuild b/kde-base/xparts/xparts-3.5.9.ebuild
new file mode 100644
index 000000000000..f60796f102dc
--- /dev/null
+++ b/kde-base/xparts/xparts-3.5.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/xparts/xparts-3.5.9.ebuild,v 1.1 2008/02/20 23:36:47 philantrop Exp $
+
+KMNAME=kdebindings
+KMEXTRACTONLY="dcopc"
+KMCOPYLIB="libdcopc dcopc"
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="Allows embedding of generic XParts as KDE KParts"
+KEYWORDS="~amd64 ~x86" # broken according to upstream - 3.4a1 README
+IUSE=""
+
+DEPEND="dev-libs/glib:1
+ x11-libs/gtk+:1
+ kde-base/dcopc:3.5"
+RDEPEND="${DEPEND}"
+
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ # disable mozilla bindings/xpart, because configure doesn't seem to do so
+ # even when it doesn't detect the mozilla headers
+ sed -i -e 's:mozilla::' "${S}/xparts/Makefile.am"
+}