summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/rhythmbox/files/rhythmbox-0.6-fix_flac_test.patch')
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.6-fix_flac_test.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.6-fix_flac_test.patch b/media-sound/rhythmbox/files/rhythmbox-0.6-fix_flac_test.patch
new file mode 100644
index 000000000000..8a044cfccd78
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.6-fix_flac_test.patch
@@ -0,0 +1,35 @@
+diff -uNr rhythmbox-0.6.8/configure.ac rhythmbox-0.6.8.patched/configure.ac
+--- rhythmbox-0.6.8/configure.ac 2004-03-05 20:06:16.000000000 +0100
++++ rhythmbox-0.6.8.patched/configure.ac 2004-03-06 18:03:59.314696456 +0100
+@@ -272,7 +272,7 @@
+ VORBISKEYS=
+ fi
+ AC_SUBST(VORBISKEYS)
+-if test "x$enable_vorbis" = "xyes"; then
++if test x"$enable_vorbis" = "xyes"; then
+ AC_DEFINE(HAVE_VORBIS,,[Define if we have Ogg Vorbis support])
+ fi
+ AM_CONDITIONAL(HAVE_VORBIS,test "x$enable_vorbis" = "xyes")
+@@ -284,18 +284,18 @@
+ if test x"$enable_flac" = xyes && test x"$enable_mp3" != xyes; then
+ AC_MSG_ERROR([libid3tag is required for FLAC support])
+ fi
+-if test "$xenable_flac" != "xno" && test x"$enable_mp3" = xyes; then
++if test x"$enable_flac" != "xno" && test x"$enable_mp3" = xyes; then
+ AC_CHECK_HEADER(FLAC/all.h,[enable_flac=yes],)
+ fi
+-if test "x$enable_flac" = "xyes"; then
++if test x"$enable_flac" = "xyes"; then
+ LIBS="$LIBS -lFLAC"
+ FLACKEYS=",application/x-flac,audio/x-flac"
+ fi
+ AC_SUBST(FLACKEYS)
+-if test "x$enable_flac" = "xyes"; then
++if test x"$enable_flac" = "xyes"; then
+ AC_DEFINE(HAVE_FLAC,,[Define if we have FLAC support])
+ fi
+-AM_CONDITIONAL(HAVE_FLAC,test "x$enable_flac" = "xyes")
++AM_CONDITIONAL(HAVE_FLAC,test x"$enable_flac" = "xyes")
+
+ CFLAGS="$CFLAGS $OGG_CFLAGS $VORBIS_CFLAGS"
+ LIBS="$LIBS $OGG_LIBS $VORBIS_LIBS $VORBISFILE_LIBS $FLAC_LIBS"