summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/zapping/zapping-0.6.4-r1.ebuild')
-rw-r--r--media-video/zapping/zapping-0.6.4-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-video/zapping/zapping-0.6.4-r1.ebuild b/media-video/zapping/zapping-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..808e3efa56b3
--- /dev/null
+++ b/media-video/zapping/zapping-0.6.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-video/zapping/zapping-0.6.4-r1.ebuild,v 1.1 2002/08/31 19:36:07 spider Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Zapping is a TV- and VBI- viewer for the Gnome environment."
+SRC_URI="http://telia.dl.sourceforge.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://zapping.sourceforge.net"
+
+DEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-base/libglade-0.99.0
+ =x11-libs/gtk+-1.2*
+ >=dev-libs/libunicode-0.4
+ >=dev-libs/libxml-1.4.0
+ >=sys-devel/gettext-0.10.36
+ >=media-libs/gdk-pixbuf-0.8
+ >=media-libs/zvbi-0.2
+ >=media-libs/rte-0.4"
+RDEPEND=${DEPEND}
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+ use pam && myconf="${myconf} --enable-pam"
+ use X \
+ && myconf="${myconf} --with-x" \
+ || myconf="${myconf} --without-x"
+
+ econf ${myconf} || die
+
+ mv src/Makefile src/Makefile.orig
+ sed -e \
+ "s:\(INCLUDES = \$(COMMON_INCLUDES)\):\1 -I/usr/include/libglade-1.0 -I/usr/include/gdk-pixbuf-1.0:" \
+ src/Makefile.orig > src/Makefile
+
+ make || die
+}
+
+src_install () {
+ einstall \
+ PACKAGE_LIB_DIR=${D}/usr/lib/zapping \
+ PACKAGE_PIXMAPS_DIR=${D}/usr/share/pixmaps/zapping \
+ PLUGIN_DEFAULT_DIR=${D}/usr/lib/zapping/plugins \
+ || die
+
+ rm ${D}/usr/bin/zapzilla
+ dosym /usr/bin/zapping /usr/bin/zapzilla
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}