summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/netperf/netperf-2.6.0-r1.ebuild')
-rw-r--r--net-analyzer/netperf/netperf-2.6.0-r1.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/net-analyzer/netperf/netperf-2.6.0-r1.ebuild b/net-analyzer/netperf/netperf-2.6.0-r1.ebuild
index 2b5d0aeb56d2..330756b33477 100644
--- a/net-analyzer/netperf/netperf-2.6.0-r1.ebuild
+++ b/net-analyzer/netperf/netperf-2.6.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.6.0-r1.ebuild,v 1.2 2012/09/27 15:52:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netperf/netperf-2.6.0-r1.ebuild,v 1.3 2014/07/14 22:40:46 jer Exp $
-EAPI=4
+EAPI=5
inherit eutils flag-o-matic
DESCRIPTION="Network performance benchmark including tests for TCP, UDP, sockets, ATM and more."
@@ -15,24 +15,22 @@ SLOT="0"
IUSE="demo sctp"
DEPEND=">=sys-apps/sed-4"
-RDEPEND=""
src_prepare() {
- sed -i src/netserver.c \
- -e '/^#define DEBUG_LOG_FILE_DIR/s:"/tmp/":"/var/log/":' \
- -e 's:sizeof(netperf_response) - 7:MAXSPECDATA:g' \
- || die
-
- epatch "${FILESDIR}"/${PN}-fix-scripts.patch
+ epatch \
+ "${FILESDIR}"/${PN}-fix-scripts.patch \
+ "${FILESDIR}"/${P}-log-dir.patch
# Fixing paths in scripts
- sed -i -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
- doc/examples/sctp_stream_script \
- doc/examples/tcp_range_script \
- doc/examples/tcp_rr_script \
- doc/examples/tcp_stream_script \
- doc/examples/udp_rr_script \
- doc/examples/udp_stream_script
+ sed -i \
+ -e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
+ doc/examples/sctp_stream_script \
+ doc/examples/tcp_range_script \
+ doc/examples/tcp_rr_script \
+ doc/examples/tcp_stream_script \
+ doc/examples/udp_rr_script \
+ doc/examples/udp_stream_script \
+ || die
# netlib.c:2292:5: warning: implicit declaration of function ‘sched_setaffinity’
# nettest_omni.c:2943:5: warning: implicit declaration of function ‘splice’
@@ -61,5 +59,5 @@ src_install () {
dodoc AUTHORS ChangeLog NEWS README Release_Notes
dodir /usr/share/doc/${PF}/examples
#Scripts no longer get installed by einstall
- cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples
+ cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples || die
}