summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/atftp/atftp-0.6-r3.ebuild')
-rw-r--r--net-ftp/atftp/atftp-0.6-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-ftp/atftp/atftp-0.6-r3.ebuild b/net-ftp/atftp/atftp-0.6-r3.ebuild
new file mode 100644
index 000000000000..6b87376bddd8
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.6-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/atftp/atftp-0.6-r3.ebuild,v 1.1 2005/04/23 04:44:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="ftp://ftp.mamalinux.com/pub/atftp/"
+SRC_URI="ftp://ftp.mamalinux.com/pub/atftp/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="x86"
+IUSE="tcpd"
+SLOT="0"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ !virtual/tftp"
+
+PROVIDE="virtual/tftp"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ epatch ${FILESDIR}/${P}-security.patch
+}
+
+src_compile () {
+ myconf=""
+ use tcpd && myconf="${myconf} --enable-libwrap" \
+ || myconf="${myconf} --disable-libwrap"
+
+ econf ${myconf} || die "./configure failed"
+
+ cp Makefile Makefile.orig
+ sed "s:CFLAGS = -g -Wall -D_REENTRANT -O2:CFLAGS = -g -Wall -D_REENTRANT ${CFLAGS}:" Makefile.orig >Makefile
+
+ emake || die
+}
+
+src_install () {
+ einstall || die "Installation failed"
+}