summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libotr/libotr-1.0.3.ebuild')
-rw-r--r--net-libs/libotr/libotr-1.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/libotr/libotr-1.0.3.ebuild b/net-libs/libotr/libotr-1.0.3.ebuild
new file mode 100644
index 000000000000..a33f03d4abdb
--- /dev/null
+++ b/net-libs/libotr/libotr-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libotr/libotr-1.0.3.ebuild,v 1.1 2005/01/21 14:48:42 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libgpg-error
+ dev-libs/libgcrypt"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}