summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/iputils/iputils-20071127.ebuild')
-rw-r--r--net-misc/iputils/iputils-20071127.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/net-misc/iputils/iputils-20071127.ebuild b/net-misc/iputils/iputils-20071127.ebuild
index 7a11aeb1968f..ce92fa6670fd 100644
--- a/net-misc/iputils/iputils-20071127.ebuild
+++ b/net-misc/iputils/iputils-20071127.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20071127.ebuild,v 1.2 2008/03/28 15:21:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-20071127.ebuild,v 1.3 2008/03/29 02:27:21 vapier Exp $
inherit flag-o-matic eutils toolchain-funcs
DESCRIPTION="Network monitoring tools including ping and ping6"
HOMEPAGE="http://www.skbuff.net/iputils/"
-SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2"
+SRC_URI="http://www.skbuff.net/iputils/iputils-s${PV}.tar.bz2
+ iputils-s${PV}-manpages.tar.bz2"
LICENSE="BSD"
SLOT="0"
@@ -45,8 +46,8 @@ src_compile() {
# We include the extra check for docbook2html
# because when we emerge from a stage1/stage2,
# it may not exist #23156
- if use doc && type -p docbook2html ; then
- emake -j1 html man || die
+ if use doc && type -P docbook2html >/dev/null ; then
+ emake -j1 html || die
fi
}
@@ -64,14 +65,11 @@ src_install() {
use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
dodoc INSTALL RELNOTES
+ use ipv6 \
+ && dosym ping.8 /usr/share/man/man8/ping6.8 \
+ || rm -f doc/*6.8
+ rm -f doc/setkey.8
+ doman doc/*.8
- if use doc ; then
- rm -f doc/setkey.8
- use ipv6 \
- && dosym ping.8 /usr/share/man/man8/ping6.8 \
- || rm -f doc/*6.8
- doman doc/*.8
-
- dohtml doc/*.html
- fi
+ use doc && dohtml doc/*.html
}