summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/fidelio/fidelio-0.9.6-r1.ebuild')
-rw-r--r--net-p2p/fidelio/fidelio-0.9.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-p2p/fidelio/fidelio-0.9.6-r1.ebuild b/net-p2p/fidelio/fidelio-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..c3995ddf11c0
--- /dev/null
+++ b/net-p2p/fidelio/fidelio-0.9.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fidelio/fidelio-0.9.6-r1.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Fidelio is a Linux/Unix client for Hotline, a proprietary protocol that combines ftp-like, irc-like and news-like functions with user authentication and permissions in one package."
+SRC_URI="http://download.sourceforge.net/fidelio/${PN}-${PV}.tar.gz"
+HOMEPAGE="http://fidelio.sourceforge.net/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ =x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.2
+ >=dev-libs/libxml2-2.4.12
+ esd? ( >=media-sound/esound-0.2.23 )"
+
+src_compile() {
+
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
+ CXXFLAGS="${CXXFLAGS} -I/usr/include/libxml2/libxml"
+ export CPPFLAGS="-I/usr/include/libxml2"
+ export XML_CONFIG="/usr/bin/xml2-config"
+ econf || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+
+}
+