summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/havp/havp-0.78.ebuild')
-rw-r--r--net-proxy/havp/havp-0.78.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/net-proxy/havp/havp-0.78.ebuild b/net-proxy/havp/havp-0.78.ebuild
deleted file mode 100644
index deb99755e60a..000000000000
--- a/net-proxy/havp/havp-0.78.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/havp/havp-0.78.ebuild,v 1.1 2006/03/29 21:43:19 mrness Exp $
-
-inherit eutils
-
-DESCRIPTION="HTTP AntiVirus Proxy"
-HOMEPAGE="http://www.server-side.de/"
-SRC_URI="http://www.server-side.de/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="ssl"
-
-DEPEND="app-antivirus/clamav"
-
-pkg_setup() {
- enewgroup havp
- enewuser havp -1 -1 /etc/havp havp
-}
-
-src_unpack() {
- unpack ${A}
-
- epatch "${FILESDIR}/${P}-gentoo.patch"
-}
-
-src_compile() {
- econf --with-scanner=libclamav \
- $(use_enable ssl ssl-tunnel) || die "configure failed"
- emake || die "make failed"
-}
-
-pkg_preinst() {
- pkg_setup
-}
-
-src_install() {
- exeinto /usr/sbin
- doexe havp/havp
-
- newinitd "${FILESDIR}/havp.initd" havp
- insinto /etc
- doins -r etc/havp
-
- diropts -m 0700 -o havp -g havp
- keepdir /var/log/havp
-
- diropts -m 0750
- dodir /var/run/havp /var/tmp/havp
-
- dodoc ChangeLog todo
-}
-
-pkg_postinst() {
- ewarn "/var/tmp/havp must be on a filesystem with mandatory locks!"
- ewarn "You should add \"mand\" to the mount options on the relevant line in /etc/fstab."
-
- if use ssl; then
- echo
- ewarn "Note: ssl USE flag only enable SSL pass-through, which means that"
- ewarn " HTTPS pages will not be scanned for viruses!"
- ewarn " It is impossible to decrypt data sent through SSL connections without knowing"
- ewarn " the private key of the used certificate."
- fi
-}