summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild')
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild
index 70698fcc4ddc..4680d1432e6f 100644
--- a/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild
+++ b/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild,v 1.7 2012/11/21 15:52:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.3.ebuild,v 1.8 2013/04/24 17:47:02 jer Exp $
EAPI=4
inherit autotools eutils user
@@ -32,6 +32,9 @@ src_prepare() {
-e "s|nobody|${PN}|g" \
-e 's|/run/tinyproxy/|/run/|g' \
etc/${PN}.conf.in || die "sed failed"
+ sed -i \
+ -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
+ configure.ac || die
eautoreconf
}
@@ -41,13 +44,14 @@ src_configure() {
export PATH="${T}:${PATH}"
fi
econf \
- --localstatedir=/var \
+ $(use_enable debug) \
$(use_enable filter-proxy filter) \
$(use_enable reverse-proxy reverse) \
$(use_enable transparent-proxy transparent) \
$(use_enable upstream-proxy upstream) \
$(use_enable xtinyproxy-header xtinyproxy) \
- $(use_enable debug)
+ --disable-silent-rules \
+ --localstatedir=/var
}
src_test() {