summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/externalmethod/ChangeLog10
-rw-r--r--net-zope/externalmethod/externalmethod-2.13.0.ebuild36
-rw-r--r--net-zope/externalmethod/metadata.xml5
-rw-r--r--net-zope/mailhost/ChangeLog10
-rw-r--r--net-zope/mailhost/mailhost-2.13.0.ebuild40
-rw-r--r--net-zope/mailhost/metadata.xml5
-rw-r--r--net-zope/mimetools/ChangeLog10
-rw-r--r--net-zope/mimetools/metadata.xml5
-rw-r--r--net-zope/mimetools/mimetools-2.13.0.ebuild33
-rw-r--r--net-zope/ofsp/ChangeLog10
-rw-r--r--net-zope/ofsp/metadata.xml5
-rw-r--r--net-zope/ofsp/ofsp-2.13.2.ebuild34
-rw-r--r--net-zope/pythonscripts/ChangeLog10
-rw-r--r--net-zope/pythonscripts/metadata.xml5
-rw-r--r--net-zope/pythonscripts/pythonscripts-2.13.0.ebuild38
-rw-r--r--net-zope/standardcachemanagers/ChangeLog10
-rw-r--r--net-zope/standardcachemanagers/metadata.xml5
-rw-r--r--net-zope/standardcachemanagers/standardcachemanagers-2.13.0.ebuild35
-rw-r--r--net-zope/zctextindex/ChangeLog10
-rw-r--r--net-zope/zctextindex/metadata.xml5
-rw-r--r--net-zope/zctextindex/zctextindex-2.13.0.ebuild46
21 files changed, 367 insertions, 0 deletions
diff --git a/net-zope/externalmethod/ChangeLog b/net-zope/externalmethod/ChangeLog
new file mode 100644
index 000000000000..e8454be5f727
--- /dev/null
+++ b/net-zope/externalmethod/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/externalmethod
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/externalmethod/ChangeLog,v 1.1 2010/09/17 21:54:12 arfrever Exp $
+
+*externalmethod-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +externalmethod-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/externalmethod/externalmethod-2.13.0.ebuild b/net-zope/externalmethod/externalmethod-2.13.0.ebuild
new file mode 100644
index 000000000000..85b5a16ccafe
--- /dev/null
+++ b/net-zope/externalmethod/externalmethod-2.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/externalmethod/externalmethod-2.13.0.ebuild,v 1.1 2010/09/17 21:54:12 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.ExternalMethod"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Products.ExternalMethod provides support for external Python methods within a Zope 2 environment."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ExternalMethod"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/extensionclass
+ net-zope/persistence
+ >=net-zope/zope-2.12"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/externalmethod/metadata.xml b/net-zope/externalmethod/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/externalmethod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/mailhost/ChangeLog b/net-zope/mailhost/ChangeLog
new file mode 100644
index 000000000000..dd570a2ce27f
--- /dev/null
+++ b/net-zope/mailhost/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/mailhost
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/mailhost/ChangeLog,v 1.1 2010/09/17 21:57:18 arfrever Exp $
+
+*mailhost-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +mailhost-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/mailhost/mailhost-2.13.0.ebuild b/net-zope/mailhost/mailhost-2.13.0.ebuild
new file mode 100644
index 000000000000..a486c0bb0a5b
--- /dev/null
+++ b/net-zope/mailhost/mailhost-2.13.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/mailhost/mailhost-2.13.0.ebuild,v 1.1 2010/09/17 21:57:18 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.MailHost"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="zope.sendmail integration for Zope 2."
+HOMEPAGE="http://pypi.python.org/pypi/Products.MailHost"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/documenttemplate
+ net-zope/persistence
+ >=net-zope/zope-2.12
+ net-zope/zope-deferredimport
+ net-zope/zope-interface
+ net-zope/zope-sendmail"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/mailhost/metadata.xml b/net-zope/mailhost/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/mailhost/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/mimetools/ChangeLog b/net-zope/mimetools/ChangeLog
new file mode 100644
index 000000000000..76413569bb1b
--- /dev/null
+++ b/net-zope/mimetools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/mimetools
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/mimetools/ChangeLog,v 1.1 2010/09/17 22:00:30 arfrever Exp $
+
+*mimetools-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +mimetools-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/mimetools/metadata.xml b/net-zope/mimetools/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/mimetools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/mimetools/mimetools-2.13.0.ebuild b/net-zope/mimetools/mimetools-2.13.0.ebuild
new file mode 100644
index 000000000000..2aa06d2f06f0
--- /dev/null
+++ b/net-zope/mimetools/mimetools-2.13.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/mimetools/mimetools-2.13.0.ebuild,v 1.1 2010/09/17 22:00:30 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="Products.MIMETools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="MIMETools provides the <!--#mime--> tag for DocumentTemplate."
+HOMEPAGE="http://pypi.python.org/pypi/Products.MIMETools"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/documenttemplate"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/ofsp/ChangeLog b/net-zope/ofsp/ChangeLog
new file mode 100644
index 000000000000..7e77f764eef0
--- /dev/null
+++ b/net-zope/ofsp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/ofsp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/ofsp/ChangeLog,v 1.1 2010/09/17 22:03:07 arfrever Exp $
+
+*ofsp-2.13.2 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +ofsp-2.13.2.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/ofsp/metadata.xml b/net-zope/ofsp/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/ofsp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/ofsp/ofsp-2.13.2.ebuild b/net-zope/ofsp/ofsp-2.13.2.ebuild
new file mode 100644
index 000000000000..c8f8f88e9315
--- /dev/null
+++ b/net-zope/ofsp/ofsp-2.13.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/ofsp/ofsp-2.13.2.ebuild,v 1.1 2010/09/17 22:03:07 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.OFSP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General Zope 2 help screens."
+HOMEPAGE="http://pypi.python.org/pypi/Products.OFSP"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/persistence
+ >=net-zope/zope-2.12"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/pythonscripts/ChangeLog b/net-zope/pythonscripts/ChangeLog
new file mode 100644
index 000000000000..aac5ad7a410c
--- /dev/null
+++ b/net-zope/pythonscripts/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/pythonscripts
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/pythonscripts/ChangeLog,v 1.1 2010/09/17 22:05:27 arfrever Exp $
+
+*pythonscripts-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pythonscripts-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/pythonscripts/metadata.xml b/net-zope/pythonscripts/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/pythonscripts/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/pythonscripts/pythonscripts-2.13.0.ebuild b/net-zope/pythonscripts/pythonscripts-2.13.0.ebuild
new file mode 100644
index 000000000000..277c595b0156
--- /dev/null
+++ b/net-zope/pythonscripts/pythonscripts-2.13.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/pythonscripts/pythonscripts-2.13.0.ebuild,v 1.1 2010/09/17 22:05:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.PythonScripts"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Products.PythonScripts provides support for restricted execution of Python scripts in Zope 2."
+HOMEPAGE="http://pypi.python.org/pypi/Products.PythonScripts"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/restrictedpython
+ net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/datetime
+ net-zope/documenttemplate
+ net-zope/zexceptions
+ >=net-zope/zope-2.12"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/standardcachemanagers/ChangeLog b/net-zope/standardcachemanagers/ChangeLog
new file mode 100644
index 000000000000..aa4ce0a53dbf
--- /dev/null
+++ b/net-zope/standardcachemanagers/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/standardcachemanagers
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/standardcachemanagers/ChangeLog,v 1.1 2010/09/17 22:08:17 arfrever Exp $
+
+*standardcachemanagers-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +standardcachemanagers-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/standardcachemanagers/metadata.xml b/net-zope/standardcachemanagers/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/standardcachemanagers/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/standardcachemanagers/standardcachemanagers-2.13.0.ebuild b/net-zope/standardcachemanagers/standardcachemanagers-2.13.0.ebuild
new file mode 100644
index 000000000000..5fa0b5fd7212
--- /dev/null
+++ b/net-zope/standardcachemanagers/standardcachemanagers-2.13.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/standardcachemanagers/standardcachemanagers-2.13.0.ebuild,v 1.1 2010/09/17 22:08:17 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.StandardCacheManagers"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Cache managers for Zope 2."
+HOMEPAGE="http://pypi.python.org/pypi/Products.StandardCacheManagers"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/transaction
+ >=net-zope/zope-2.12
+ net-zope/zope-component"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
diff --git a/net-zope/zctextindex/ChangeLog b/net-zope/zctextindex/ChangeLog
new file mode 100644
index 000000000000..7890df0cb03f
--- /dev/null
+++ b/net-zope/zctextindex/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zctextindex
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zctextindex/ChangeLog,v 1.1 2010/09/17 22:10:38 arfrever Exp $
+
+*zctextindex-2.13.0 (17 Sep 2010)
+
+ 17 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zctextindex-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zctextindex/metadata.xml b/net-zope/zctextindex/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/zctextindex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/zctextindex/zctextindex-2.13.0.ebuild b/net-zope/zctextindex/zctextindex-2.13.0.ebuild
new file mode 100644
index 000000000000..c2b99b51f880
--- /dev/null
+++ b/net-zope/zctextindex/zctextindex-2.13.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zctextindex/zctextindex-2.13.0.ebuild,v 1.1 2010/09/17 22:10:38 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+MY_PN="Products.ZCTextIndex"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Full text indexing for ZCatalog / Zope 2."
+HOMEPAGE="http://pypi.python.org/pypi/Products.ZCTextIndex"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/accesscontrol
+ net-zope/acquisition
+ net-zope/persistence
+ net-zope/transaction
+ net-zope/zexceptions
+ net-zope/zodb
+ >=net-zope/zope-2.12
+ net-zope/zope-interface"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt src/Products/ZCTextIndex/README.txt"
+PYTHON_MODNAME="${MY_PN/.//}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # http://svn.zope.org/?rev=114425&view=rev
+ sed -e "/packages=/a namespace_packages=['Products']," -i setup.py || die "sed failed"
+}