summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cxsparse/cxsparse-2.2.6.ebuild')
-rw-r--r--sci-libs/cxsparse/cxsparse-2.2.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/cxsparse/cxsparse-2.2.6.ebuild b/sci-libs/cxsparse/cxsparse-2.2.6.ebuild
new file mode 100644
index 000000000000..c8c4a2ad6df0
--- /dev/null
+++ b/sci-libs/cxsparse/cxsparse-2.2.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cxsparse/cxsparse-2.2.6.ebuild,v 1.1 2012/01/20 05:49:19 bicatali Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=CXSparse
+
+DESCRIPTION="Extended sparse matrix package."
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="sci-libs/ufconfig"
+RDEPEND=""
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${PN}-2.2.2-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"