summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/vtk/vtk-5.0.0.ebuild')
-rw-r--r--sci-libs/vtk/vtk-5.0.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sci-libs/vtk/vtk-5.0.0.ebuild b/sci-libs/vtk/vtk-5.0.0.ebuild
index 4c913bbf1e84..485afe8f849c 100644
--- a/sci-libs/vtk/vtk-5.0.0.ebuild
+++ b/sci-libs/vtk/vtk-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.6 2006/06/12 12:38:38 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.7 2006/06/23 01:13:23 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
@@ -37,6 +37,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/VTK
+
+pkg_setup() {
+ if use qt3 && use qt4; then
+ echo
+ ewarn "qt3 and qt4 support for vtk are mutually exclusive and"
+ ewarn "qt4 support has therefore been enabled by default."
+ echo
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"