summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dcron/dcron-2.9-r2.ebuild')
-rw-r--r--sys-apps/dcron/dcron-2.9-r2.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-apps/dcron/dcron-2.9-r2.ebuild b/sys-apps/dcron/dcron-2.9-r2.ebuild
index 1fc4ec784223..95875c5af8b4 100644
--- a/sys-apps/dcron/dcron-2.9-r2.ebuild
+++ b/sys-apps/dcron/dcron-2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r2.ebuild,v 1.16 2004/10/01 00:24:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.9-r2.ebuild,v 1.17 2004/10/05 12:59:59 vapier Exp $
inherit eutils
@@ -11,7 +11,7 @@ SRC_URI="http://apollo.backplane.com/FreeSrc/${PN}${MY_PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="arm alpha amd64 hppa ia64 mips ppc ppc64 s390 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
IUSE=""
DEPEND="virtual/libc
@@ -30,12 +30,10 @@ src_unpack() {
epatch ${FILESDIR}/dcron-2.9-ldflags.patch
# fix 'crontab -e' to look at $EDITOR and not $VISUAL
- sed -i 's:VISUAL:EDITOR:g' ${S}/crontab.c
-
- sed -i 's:VISUAL:EDITOR:g' ${S}/crontab.1
+ sed -i 's:VISUAL:EDITOR:g' crontab.{c,1}
# remove gcc hardcode
- sed -i "s:\(CC = \)gcc:\1${CC:-gcc}:" ${S}/Makefile
+ sed -i "s:\(CC = \)gcc:\1${CC:-gcc}:" Makefile
}
src_compile() {