summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/btrace/btrace-0.99.3.ebuild')
-rw-r--r--sys-block/btrace/btrace-0.99.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-block/btrace/btrace-0.99.3.ebuild b/sys-block/btrace/btrace-0.99.3.ebuild
new file mode 100644
index 000000000000..cb6ad0e7b86b
--- /dev/null
+++ b/sys-block/btrace/btrace-0.99.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/btrace/btrace-0.99.3.ebuild,v 1.1 2008/05/28 18:17:37 robbat2 Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="btrace can show detailed info about what is happening on a block device io queue."
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/axboe/blktrace/"
+MY_PN="blktrace"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="http://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="virtual/libc"
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ || ( sys-kernel/linux-headers sys-kernel/mips-headers )
+ doc? ( virtual/tetex )
+ dev-libs/libaio"
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() {
+ append-flags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" prefix="/usr" mandir="/usr/share/man" || die "emake install failed"
+ dodoc README
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}