summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/partimage/files')
-rw-r--r--sys-block/partimage/files/partimage-0.6.4-save_file_and_rest_file_actions.patch127
-rw-r--r--sys-block/partimage/files/partimage-0.6.6-disable_header_check.patch15
-rw-r--r--sys-block/partimage/files/partimage-0.6.6-not_install_info.patch21
-rw-r--r--sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch12
-rw-r--r--sys-block/partimage/files/partimage-0.6.7-chown.patch38
-rw-r--r--sys-block/partimage/files/partimage-0.6.7-datadir-path.patch11
-rw-r--r--sys-block/partimage/files/partimage-0.6.7-gcc43.patch36
7 files changed, 0 insertions, 260 deletions
diff --git a/sys-block/partimage/files/partimage-0.6.4-save_file_and_rest_file_actions.patch b/sys-block/partimage/files/partimage-0.6.4-save_file_and_rest_file_actions.patch
deleted file mode 100644
index 0c61a85673e7..000000000000
--- a/sys-block/partimage/files/partimage-0.6.4-save_file_and_rest_file_actions.patch
+++ /dev/null
@@ -1,127 +0,0 @@
---- partimage-0.6.4.orig/src/client/main.cpp 2006-10-14 14:09:50.000000000 +0200
-+++ partimage-0.6.4/src/client/main.cpp 2006-10-14 14:00:30.000000000 +0200
-@@ -517,6 +517,10 @@
- else if (strcmp(argv[optind], "imginfo")==0)
- // show informations about the imagefile
- nChoice = OPERATION_IMGINFO;
-+ else if (strcmp(argv[optind], "save_file")==0)
-+ nChoice = OPERATION_SAVE_FILE;
-+ else if (strcmp(argv[optind], "rest_file")==0)
-+ nChoice = OPERATION_REST_FILE;
- else if (strcmp(argv[optind], "save_all")==0)
- nChoice = OPERATION_SAVE_ALL;
- else if (strcmp(argv[optind], "rest_all")==0)
-@@ -690,7 +694,35 @@
- nRes = -1;
- }
- break;
--
-+
-+ case OPERATION_SAVE_FILE:
-+ showDebug(1, "action=SAVE_FILE\n");
-+ try { save_file(szImageFile, &options); }
-+ catch (CExceptions *excep)
-+ {
-+ showDebug(1, "save_file caught exception: %d\n", excep->GetExcept());
-+
-+ if (options.bBatchMode) ensure_interface_is_non_interactive();
-+ g_interface -> Error(excep, szImageFile, "");
-+
-+ nRes = -1;
-+ }
-+ break;
-+
-+ case OPERATION_REST_FILE:
-+ showDebug(1, "action=REST_FILE\n");
-+ try { rest_file(szImageFile, &options); }
-+ catch (CExceptions *excep)
-+ {
-+ showDebug(1, "rest_file caught exception: %d\n", excep->GetExcept());
-+
-+ if (options.bBatchMode) ensure_interface_is_non_interactive();
-+ g_interface -> Error(excep, szImageFile, "");
-+
-+ nRes = -1;
-+ }
-+ break;
-+
- default: // exit
- if (options.bSync)
- {
---- partimage-0.6.4.orig/src/client/misc.cpp 2006-10-14 14:09:50.000000000 +0200
-+++ partimage-0.6.4/src/client/misc.cpp 2006-10-14 14:04:24.000000000 +0200
-@@ -2502,3 +2502,52 @@
-
- RETURN;
- }
-+
-+void save_file(char *szImageFile, COptions *options)
-+{
-+ BEGIN;
-+ int in_offset = 0;
-+ char *in = (char *) malloc(MAXPATHLEN);
-+
-+ CImage image(options);
-+ image.set_szImageFilename(szImageFile);
-+ image.openWriting();
-+
-+ while (1) {
-+ int len = fread(in + in_offset, 1, MAXPATHLEN, stdin);
-+ showDebug(1, "read %d chars on stdin\n", len);
-+ if (!len) break;
-+ in = (char *) realloc(in, MAXPATHLEN + (in_offset += len));
-+ }
-+ showDebug(1, "writing %d chars in %s\n", in_offset, szImageFile);
-+ write_unsigned(&image, in_offset);
-+ image.write((void *) in, in_offset, true);
-+ free(in);
-+
-+ closeFilesSave(false, *options, &image, NULL);
-+
-+ RETURN;
-+}
-+
-+void rest_file(char *szImageFile, COptions *options)
-+{
-+ BEGIN;
-+
-+ CImage image(options);
-+
-+ {
-+ image.set_szImageFilename(szImageFile);
-+ image.openReading();
-+
-+ unsigned int len = read_unsigned(&image);
-+ char *s = (char *) malloc(len + 1);
-+ image.read(s, len, true);
-+ fwrite(s, 1, len, stdout);
-+ free(s);
-+
-+ // since sfdisk.lst is not really nice to the library, we can't close the thread from procReadBuffer$
-+ image.closeReading(false);
-+ }
-+
-+ RETURN;
-+}
---- partimage-0.6.4.orig/src/client/misc.h 2006-10-14 14:09:50.000000000 +0200
-+++ partimage-0.6.4/src/client/misc.h 2006-10-14 14:00:30.000000000 +0200
-@@ -47,6 +47,8 @@
- void savePartition(char *szDevice, char *szImageName, /*char *szFilesystem, */COptions *options);
- void restorePartition(char *szDevice, char *szImageName, COptions *options);
- void restoreMbr(char *szImageFile, COptions *options);
-+void save_file(char *szImageFile, COptions *options);
-+void rest_file(char *szImageFile, COptions *options);
- void save_all(char *szImageDir, COptions *options);
- void rest_all(char *szImageDir, COptions *options);
-
---- partimage-0.6.4.orig/src/client/partimage.h 2006-10-14 14:09:50.000000000 +0200
-+++ partimage-0.6.4/src/client/partimage.h 2006-10-14 14:09:18.000000000 +0200
-@@ -96,6 +96,8 @@
- #define OPERATION_EXIT 5
- #define OPERATION_SAVE_ALL 6
- #define OPERATION_REST_ALL 7
-+#define OPERATION_SAVE_FILE 8
-+#define OPERATION_REST_FILE 9
-
- // returned by CExceptionsGUI::windowError
- // user canceled the job
diff --git a/sys-block/partimage/files/partimage-0.6.6-disable_header_check.patch b/sys-block/partimage/files/partimage-0.6.6-disable_header_check.patch
deleted file mode 100644
index 37c32a81035c..000000000000
--- a/sys-block/partimage/files/partimage-0.6.6-disable_header_check.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -uNr partimage-0.6.6.orig/src/client/main.cpp partimage-0.6.6/src/client/main.cpp
---- partimage-0.6.6.orig/src/client/main.cpp 2008-01-15 00:39:28.000000000 +0100
-+++ partimage-0.6.6/src/client/main.cpp 2008-01-15 01:30:57.000000000 +0100
-@@ -1015,6 +1015,11 @@
- // =======================================================
- int checkStructSizes()
- {
-+ // Disable header check for AMD64, because it fails
-+#if defined(__x86_64__)
-+ return 0;
-+#endif
-+
- // ---- check types sizes
-
- if (sizeof(DWORD) != 4)
diff --git a/sys-block/partimage/files/partimage-0.6.6-not_install_info.patch b/sys-block/partimage/files/partimage-0.6.6-not_install_info.patch
deleted file mode 100644
index e4d1f7162c1f..000000000000
--- a/sys-block/partimage/files/partimage-0.6.6-not_install_info.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -uNr partimage-0.6.6.orig/Makefile.in partimage-0.6.6/Makefile.in
---- partimage-0.6.6.orig/Makefile.in 2008-01-14 23:11:07.000000000 +0100
-+++ partimage-0.6.6/Makefile.in 2008-01-14 23:14:55.000000000 +0100
-@@ -703,17 +703,6 @@
- chmod 600 ${DESTDIR}${sysconfdir}/partimaged/partimagedusers ;\
- fi
-
-- $(mkinstalldirs) ${DESTDIR}${infodir}
-- $(INSTALL_DATA) AUTHORS ${DESTDIR}${infodir}/AUTHORS
-- $(INSTALL_DATA) BUGS ${DESTDIR}${infodir}/BUGS
-- $(INSTALL_DATA) COPYING ${DESTDIR}${infodir}/COPYING
-- $(INSTALL_DATA) ChangeLog ${DESTDIR}${infodir}/ChangeLog
-- $(INSTALL_DATA) INSTALL ${DESTDIR}${infodir}/INSTALL
-- $(INSTALL_DATA) README ${DESTDIR}${infodir}/README
-- $(INSTALL_DATA) README.partimaged ${DESTDIR}${infodir}/README.partimaged
-- $(INSTALL_DATA) TODO ${DESTDIR}${infodir}/TODO
-- $(INSTALL_DATA) partimage.lsm ${DESTDIR}${infodir}/partimage.lsm
--
- uninstall-local:
- -rm -f ${infodir}/AUTHORS
- -rm -f ${infodir}/BUGS
diff --git a/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch b/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch
deleted file mode 100644
index c8b2fed20ece..000000000000
--- a/sys-block/partimage/files/partimage-0.6.7+glibc-2.10.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur partimage-0.6.7/src/client/misc.cpp partimage-0.6.7-new/src/client/misc.cpp
---- partimage-0.6.7/src/client/misc.cpp 2008-02-03 19:58:00.000000000 -0200
-+++ partimage-0.6.7-new/src/client/misc.cpp 2009-02-26 12:57:45.000000000 -0300
-@@ -2372,7 +2372,7 @@
-
- static char *sfdisk_line_to_partition_device(const char *line)
- {
-- if (char *p = strchr(line, ':')) {
-+ if (const char *p = strchr(line, ':')) {
- while (p[-1] == ' ' && p > line) p--;
- return strndup(line, p - line);
- } else {
diff --git a/sys-block/partimage/files/partimage-0.6.7-chown.patch b/sys-block/partimage/files/partimage-0.6.7-chown.patch
deleted file mode 100644
index e28d18fcb05b..000000000000
--- a/sys-block/partimage/files/partimage-0.6.7-chown.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- partimage-0.6.7/Makefile.in.orig 2008-02-26 19:56:15.000000000 +0100
-+++ partimage-0.6.7/Makefile.in 2008-02-26 19:56:25.000000000 +0100
-@@ -708,8 +708,6 @@
- rm -f $(DESTDIR)${sysconfdir}/partimaged/partimaged.csr ;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimaged.key || true;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimaged.cert || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimaged.key || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimaged.cert || true;\
- else \
- echo "SSL disabled, no certificate will be generated." ;\
- fi
-@@ -741,7 +739,6 @@
- echo "#sample # user 'sample' is allowed to connect partimaged" >> \
- $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimagedusers || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimagedusers || true ;\
- fi
-
- distclean-local:
---- partimage-0.6.7/Makefile.am.orig 2008-02-26 19:55:53.000000000 +0100
-+++ partimage-0.6.7/Makefile.am 2008-02-26 19:56:11.000000000 +0100
-@@ -21,8 +21,6 @@
- rm -f $(DESTDIR)${sysconfdir}/partimaged/partimaged.csr ;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimaged.key || true;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimaged.cert || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimaged.key || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimaged.cert || true;\
- else \
- echo "SSL disabled, no certificate will be generated." ;\
- fi
-@@ -55,7 +53,6 @@
- echo "#sample # user 'sample' is allowed to connect partimaged" >> \
- $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
- chmod 600 $(DESTDIR)${sysconfdir}/partimaged/partimagedusers || true;\
-- chown partimag:root $(DESTDIR)${sysconfdir}/partimaged/partimagedusers || true ;\
- fi
-
- distclean-local:
diff --git a/sys-block/partimage/files/partimage-0.6.7-datadir-path.patch b/sys-block/partimage/files/partimage-0.6.7-datadir-path.patch
deleted file mode 100644
index f9c315f91dd9..000000000000
--- a/sys-block/partimage/files/partimage-0.6.7-datadir-path.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- partimage-0.6.7/Makefile.in.orig 2008-02-26 19:59:54.000000000 +0100
-+++ partimage-0.6.7/Makefile.in 2008-02-26 20:00:16.000000000 +0100
-@@ -732,7 +732,7 @@
- $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
- echo -n "#add only users allowed to " >> \
- $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
-- echo "connect partimaged" >> ${sysconfdir}/partimaged/partimagedusers ;\
-+ echo "connect partimaged" >> $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
- echo "# (only one login per line)" >> \
- $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
- echo "" >> $(DESTDIR)${sysconfdir}/partimaged/partimagedusers ;\
diff --git a/sys-block/partimage/files/partimage-0.6.7-gcc43.patch b/sys-block/partimage/files/partimage-0.6.7-gcc43.patch
deleted file mode 100644
index af37ee1c063e..000000000000
--- a/sys-block/partimage/files/partimage-0.6.7-gcc43.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naurp partimage-0.6.7-orig/src/shared/net.h partimage-0.6.7/src/shared/net.h
---- partimage-0.6.7-orig/src/shared/net.h 2008-02-03 15:57:55.000000000 -0600
-+++ partimage-0.6.7/src/shared/net.h 2008-07-16 20:04:02.000000000 -0600
-@@ -28,7 +28,7 @@
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
--#include <iostream.h>
-+#include <iostream>
- #include <pthread.h>
-
- #include "pathnames.h"
-diff -Naurp partimage-0.6.7-orig/src/server/partimaged.cpp partimage-0.6.7/src/server/partimaged.cpp
---- partimage-0.6.7-orig/src/server/partimaged.cpp 2008-02-03 15:57:53.000000000 -0600
-+++ partimage-0.6.7/src/server/partimaged.cpp 2008-07-16 20:10:04.000000000 -0600
-@@ -22,7 +22,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
--#include <iostream.h>
-+#include <iostream>
-
- #include "net.h"
- #include "netserver.h"
-diff -Naurp partimage-0.6.7-orig/src/server/partimaged-main.cpp partimage-0.6.7/src/server/partimaged-main.cpp
---- partimage-0.6.7-orig/src/server/partimaged-main.cpp 2008-02-03 15:57:53.000000000 -0600
-+++ partimage-0.6.7/src/server/partimaged-main.cpp 2008-07-16 20:10:45.000000000 -0600
-@@ -27,7 +27,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
--#include <iostream.h>
-+#include <iostream>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <signal.h>