summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-2.02_beta2-r7.ebuild')
-rw-r--r--sys-boot/grub/grub-2.02_beta2-r7.ebuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/sys-boot/grub/grub-2.02_beta2-r7.ebuild b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
index f32ec279a855..93ec2a7117c7 100644
--- a/sys-boot/grub/grub-2.02_beta2-r7.ebuild
+++ b/sys-boot/grub/grub-2.02_beta2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.6 2015/02/07 20:38:02 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.02_beta2-r7.ebuild,v 1.7 2015/03/16 21:39:48 vapier Exp $
EAPI=5
@@ -141,18 +141,6 @@ QA_PRESTRIPPED="
usr/lib.*/grub/.*/kernel.img
"
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- # Bug 439082
- if ! test-flags-CC -fuse-ld=bfd > /dev/null &&
- $(tc-getLD) --version | grep -q "GNU gold"; then
- eerror "GRUB does not function correctly when built with the gold linker."
- eerror "Please select the bfd linker with binutils-config."
- die "GNU gold detected"
- fi
- fi
-}
-
src_unpack() {
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
@@ -256,8 +244,7 @@ src_configure() {
use static && HOST_LDFLAGS+=" -static"
- export TARGET_LDFLAGS+=" $(test-flags-CC -fuse-ld=bfd)"
-
+ tc-ld-disable-gold #439082 #466536 #526348
tc-export CC NM OBJCOPY STRIP
export TARGET_CC=${TARGET_CC:-${CC}}
tc-export BUILD_CC # Bug 485592