summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.5.3.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.5.3.ebuild b/sys-cluster/openmpi/openmpi-1.5.3.ebuild
index fef646a0bb6d..572dee6b9c72 100644
--- a/sys-cluster/openmpi/openmpi-1.5.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3.ebuild,v 1.5 2011/06/21 14:22:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.3.ebuild,v 1.6 2011/06/24 15:09:06 jlec Exp $
EAPI=3
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs
@@ -17,7 +17,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="+cxx elibc_FreeBSD fortran heterogeneous ipv6 mpi-threads pbs romio threads vt"
RDEPEND="
fortran? ( virtual/fortran )
-pbs? ( sys-cluster/torque )
+ pbs? ( sys-cluster/torque )
vt? (
!dev-libs/libotf
!app-text/lcdf-typetools
@@ -31,7 +31,7 @@ pbs? ( sys-cluster/torque )
DEPEND="${RDEPEND}"
pkg_setup() {
- fortran-2_pkg_setup
+ use fortran && fortran-2_pkg_setup
if use mpi-threads; then
echo
ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"