summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-power/cpufreqd/cpufreqd-2.3.4.ebuild')
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.3.4.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild b/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild
new file mode 100644
index 000000000000..305682943814
--- /dev/null
+++ b/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.3.4.ebuild,v 1.1 2009/10/20 13:06:45 bangert Exp $
+
+EAPI="2"
+
+inherit eutils
+
+NVCLOCK_VERSION="0.8b"
+
+DESCRIPTION="CPU Frequency Daemon"
+HOMEPAGE="http://www.linux.it/~malattia/wiki/index.php/Cpufreqd"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+ nvidia? ( http://www.linuxhardware.org/nvclock/nvclock${NVCLOCK_VERSION}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="acpi apm lm_sensors nforce2 nvidia pmu"
+RDEPEND=">=sys-power/cpufrequtils-002
+ lm_sensors? ( <sys-apps/lm_sensors-3 )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-conf.d.patch
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ epatch "${FILESDIR}"/nvclock${NVCLOCK_VERSION}-fpic.patch
+ fi
+}
+
+src_configure() {
+ local config
+
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ econf \
+ --disable-gtk \
+ --disable-qt \
+ --disable-nvcontrol \
+ || die "econf nvclock failed"
+ emake -j1 || die "emake nvclock failed"
+ config="--enable-nvclock=${WORKDIR}/nvclock${NVCLOCK_VERSION}"
+ fi
+
+ cd "${S}"
+ econf \
+ $(use_enable acpi) \
+ $(use_enable apm) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nforce2) \
+ $(use_enable pmu) \
+ ${config} \
+ || die "econf failed"
+}
+
+src_compile() {
+ if use nvidia; then
+ cd "${WORKDIR}"/nvclock${NVCLOCK_VERSION}
+ fi
+
+ cd "${S}"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -rf "${D}"/usr/$(get_libdir)/*.la
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ newinitd "${FILESDIR}"/${PN}-init.d ${PN}
+}
+
+pkg_postinst() {
+ if [ -f "${ROOT}"/etc/conf.d/cpufreqd ] ; then
+ ewarn "An old \"/etc/conf.d/cpufreqd\" file was found. It breaks"
+ ewarn "the new init script! Please remove it."
+ ewarn "# rm /etc/conf.d/cpufreqd"
+ fi
+}