summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/rekonq/rekonq-0.9.0.ebuild')
-rw-r--r--www-client/rekonq/rekonq-0.9.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/www-client/rekonq/rekonq-0.9.0.ebuild b/www-client/rekonq/rekonq-0.9.0.ebuild
new file mode 100644
index 000000000000..5f9f9661c09c
--- /dev/null
+++ b/www-client/rekonq/rekonq-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/rekonq/rekonq-0.9.0.ebuild,v 1.1 2012/03/22 12:57:23 johu Exp $
+
+EAPI=4
+
+WEBKIT_REQUIRED="always"
+QT_MINIMAL="4.8"
+KDE_MINIMAL="4.7"
+KDE_SCM="git"
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
+hu is it ja ko lt nb nds pl pt pt_BR ro ru sk sl sr sr@ijekavian
+sr@ijekavianlatin sr@latin sv th tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+#upstream re-released 0.9.0
+MY_P=${P}-1
+
+DESCRIPTION="A browser based on qt-webkit"
+HOMEPAGE="http://rekonq.kde.org/"
+[[ ${PV} != *9999* ]] && SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+# All test fails
+RESTRICT="test"
+
+src_prepare() {
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+ kde4-base_src_prepare
+}