summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild')
-rw-r--r--www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild b/www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild
new file mode 100644
index 000000000000..f7ceb617f2b7
--- /dev/null
+++ b/www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/profile-sync-daemon/profile-sync-daemon-5.36.4_p20130721.ebuild,v 1.1 2013/07/21 00:45:57 hasufell Exp $
+
+EAPI=5
+
+inherit eutils vcs-snapshot
+
+DESCRIPTION="Symlinks and syncs browser profile dirs to RAM"
+HOMEPAGE="https://wiki.archlinux.org/index.php/Profile-sync-daemon"
+SRC_URI="https://github.com/graysky2/profile-sync-daemon/archive/f78e3f3cc1c02757c0025fa5d5e311015a13e9dc.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ net-misc/rsync"
+
+src_install() {
+ emake DESTDIR="${ED}" install-openrc-all install-systemd
+ fperms -x /etc/cron.hourly/psd-update
+}
+
+pkg_postinst() {
+ elog "The cronjob is -x by default."
+ elog "You might want to set it +x if you don't use"
+ elog "the systemd provided \"psd-resync.timer\"."
+}