summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libsexy/libsexy-0.1.11-r2.ebuild')
-rw-r--r--x11-libs/libsexy/libsexy-0.1.11-r2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild b/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild
index 18f1f86bd5ad..b1930c1ee9fd 100644
--- a/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild
+++ b/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild,v 1.1 2010/02/25 20:50:54 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/libsexy-0.1.11-r2.ebuild,v 1.2 2011/04/04 15:17:51 ssuominen Exp $
EAPI=3
inherit autotools eutils
@@ -12,7 +12,7 @@ SRC_URI="http://releases.chipx86.com/${PN}/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND=">=dev-libs/glib-2.6:2
>=x11-libs/gtk+-2.6:2
@@ -38,6 +38,7 @@ src_prepare() {
src_configure() {
econf \
--disable-dependency-tracking \
+ $(use_enable static-libs static) \
$(use_enable doc gtk-doc) \
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
}
@@ -45,4 +46,6 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
}