summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild')
-rw-r--r--x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild36
1 files changed, 17 insertions, 19 deletions
diff --git a/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild b/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
index be0768dae1ed..e372510ee826 100644
--- a/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
+++ b/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild
@@ -1,46 +1,44 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild,v 1.7 2006/10/11 11:17:53 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fspanel/fspanel-0.8_beta1-r2.ebuild,v 1.8 2006/10/22 00:05:32 omp Exp $
+
+MY_P=${P/_beta/beta}
-S=${WORKDIR}/fspanel-0.8beta1
DESCRIPTION="F***ing Small Panel. Good (and small) replacement for gnome-panel"
-SRC_URI="http://www.chatjunkies.org/fspanel/fspanel-0.8beta1.tar.gz"
HOMEPAGE="http://www.chatjunkies.org/fspanel"
+SRC_URI="http://www.chatjunkies.org/fspanel/${MY_P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc ppc ~amd64"
IUSE=""
-LICENSE="GPL-2"
-RDEPEND="|| ( (
- x11-libs/libX11
- x11-libs/libXpm
- x11-libs/libXft )
- virtual/x11 )"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXft"
DEPEND="${RDEPEND}
- || ( x11-proto/xproto virtual/x11 )
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ x11-proto/xproto"
-src_unpack() {
+S=${WORKDIR}/${MY_P}
+src_unpack() {
unpack ${A}
sed -i -e 's,/X11R6,,g' "${S}/configure"
-
}
src_compile() {
-
- if pkg-config xft
- then
+ if pkg-config xft; then
CFLAGS="${CFLAGS} -I/usr/include/freetype2"
fi
- ./configure
- emake || die
+
+ ./configure || die "configure failed"
+ emake || die "emake failed"
}
src_install () {
exeinto /usr/bin
- doexe ${S}/fspanel
+ doexe "${S}/fspanel"
dodoc README
}