aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2017-03-11 11:49:33 -0800
committerSteve Arnold <nerdboy@gentoo.org>2017-03-11 11:49:33 -0800
commit77039e85e774ffa9eae7223916f7e360362e8ab9 (patch)
tree4ea7aec8d97d9bfb0e513e71703fb6c8881e8c03 /dev-libs
parentwww-client/firefox: remove stale beta (diff)
downloadarm-77039e85e774ffa9eae7223916f7e360362e8ab9.tar.gz
arm-77039e85e774ffa9eae7223916f7e360362e8ab9.tar.bz2
arm-77039e85e774ffa9eae7223916f7e360362e8ab9.zip
redis-ipc-0.0.1: new ebuild, still testing autotools config
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/redis-ipc/Manifest1
-rw-r--r--dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch102
-rw-r--r--dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild43
3 files changed, 146 insertions, 0 deletions
diff --git a/dev-libs/redis-ipc/Manifest b/dev-libs/redis-ipc/Manifest
new file mode 100644
index 0000000..ce352fd
--- /dev/null
+++ b/dev-libs/redis-ipc/Manifest
@@ -0,0 +1 @@
+DIST redis-ipc-0.0.1.tar.gz 37652 SHA256 28cb0fc70441698f2e9c23697adb80e719e77e614241c71b7a95b532a49fc3d2 SHA512 6bf4cf4021953ccc6b9b6750492d469afbc2c09d5551d4993d7c9af3049237b7df6d261866cedca1a719d14ceefd2f6eb1add638fb97b03e3c55522114489e4c WHIRLPOOL f6d19fcfa7d79039aa58996c09a4cacea7381774a4a666be68754cc40300481b7b6bc4bfc94ac78f81595218294b0cce29916db2ada13fcbacee780c5ecaed83
diff --git a/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch b/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch
new file mode 100644
index 0000000..b9a0410
--- /dev/null
+++ b/dev-libs/redis-ipc/files/redis-ipc-0.0.1-fix-qa-warning.patch
@@ -0,0 +1,102 @@
+diff --git a/configure.ac b/configure.ac
+index 595873b..ce52489 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -53,8 +53,8 @@ JSON_C_MIN_VERSION="0.9"
+ PKG_CHECK_MODULES(JSONC, libjson-c >= $JSON_C_MIN_VERSION, ,
+ AC_CHECK_HEADER(json-c/json.h, [JSONC_LIBS="-ljson-c"], [json-c=no])
+ AC_CHECK_HEADER(json-c/json.h, [JSONC_CFLAGS="-I$includedir"
+- JSONC_LIBS="-L$libdir -ljson-c"], [json-c=no])
+- AC_SUBST([JSONC_CFLAGS])
++ JSONC_LIBS="-L$libdir -ljson-c"], [json-c=no])
++ #AC_SUBST([JSONC_CFLAGS])
+ AC_SUBST([JSONC_LIBS])
+ )
+
+@@ -62,7 +62,7 @@ PKG_CHECK_MODULES(HIREDIS, libhiredis, ,
+ AC_CHECK_HEADER(hiredis/hiredis.h, [HIREDIS_LIBS="-lhiredis"], [hiredis=no])
+ AC_CHECK_HEADER(hiredis/hiredis.h, [HIREDIS_CFLAGS="-I$includedir"
+ HIREDIS_LIBS="-L$libdir -lhiredis"], [hiredis=no])
+- AC_SUBST([HIREDIS_CFLAGS])
++ #AC_SUBST([HIREDIS_CFLAGS])
+ AC_SUBST([HIREDIS_LIBS])
+ )
+ #[
+diff --git a/src/redis_ipc.c b/src/redis_ipc.c
+index 84d7c2a..cc2e9cc 100644
+--- a/src/redis_ipc.c
++++ b/src/redis_ipc.c
+@@ -207,7 +207,11 @@ int get_debug_verbosity()
+ //@@@@ FIXME: debug will be dynamically configurable from a setting or config file
+ int stderr_debug_is_enabled()
+ {
++#if ENABLE_DEBUG
+ return 1;
++#else
++ return 0;
++#endif
+ }
+
+ // check for errors in redis command execution;
+diff --git a/src/redis_ipc.h b/src/redis_ipc.h
+index c603c21..c3820d5 100644
+--- a/src/redis_ipc.h
++++ b/src/redis_ipc.h
+@@ -4,6 +4,7 @@
+
+ #include <sys/types.h>
+ #include <json-c/json.h>
++#include <config.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+@@ -94,7 +95,10 @@ int redis_ipc_cleanup(pid_t tid);
+ // is received, it will be logged as an error to submitter component's
+ // debug channel then freed, and the wait on results queue will restart
+ // (expiration time will be reset to original).
+-//
++
++int get_debug_verbosity();
++int stderr_debug_is_enabled();
++
+ // After receiving and executing a command, the receiving component
+ // should submit a result. The original command is passed in as a parameter
+ // to provide the command ID and path to results queue. The command ID
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 5493edc..eb05acf 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -1,4 +1,4 @@
+-AM_CPPFLAGS = -I$(top_srcdir)/inc -I$(top_srcdir)/src -I$(includedir)
++AM_CPPFLAGS = -I$(top_srcdir)/inc -I$(top_srcdir)/src
+
+ LIBREDISIPC = $(top_srcdir)/src/.libs/libredis_ipc.la
+
+@@ -14,22 +14,22 @@ check_PROGRAMS = $(BUILT_TESTS)
+ include_HEADERS = $(top_srcdir)/inc/json.hh
+
+ command_result_test_SOURCES = command_result_test.c
+-command_result_test_LDADD = -lhiredis -ljson-c $(LIBREDISIPC) -lpthread
++command_result_test_LDADD = $(HIREDIS_LIBS) $(JSONC_LIBS) $(LIBREDISIPC) -lpthread
+ command_result_test_LDFLAGS = -Wl,--hash-style=gnu -no-install
+
+ json_test_SOURCES = json_test.cpp
+-json_test_LDADD = -lhiredis -ljson-c $(LIBREDISIPC) -lpthread
++json_test_LDADD = $(HIREDIS_LIBS) $(JSONC_LIBS) $(LIBREDISIPC) -lpthread
+ json_test_LDFLAGS = -Wl,--hash-style=gnu -no-install
+
+ multithread_test_SOURCES = multithread_test.c
+-multithread_test_LDADD = -lhiredis -ljson-c $(LIBREDISIPC) -lpthread
++multithread_test_LDADD = $(HIREDIS_LIBS) $(JSONC_LIBS) $(LIBREDISIPC) -lpthread
+ multithread_test_LDFLAGS = -Wl,--hash-style=gnu -no-install
+
+ pub_sub_test_SOURCES = pub_sub_test.c
+-pub_sub_test_LDADD = -lhiredis -ljson-c $(LIBREDISIPC) -lpthread
++pub_sub_test_LDADD = $(HIREDIS_LIBS) $(JSONC_LIBS) $(LIBREDISIPC) -lpthread
+ pub_sub_test_LDFLAGS = -Wl,--hash-style=gnu -no-install
+
+ settings_status_test_SOURCES = settings_status_test.c
+-settings_status_test_LDADD = -lhiredis -ljson-c $(LIBREDISIPC) -lpthread
++settings_status_test_LDADD = $(HIREDIS_LIBS) $(JSONC_LIBS) $(LIBREDISIPC) -lpthread
+ settings_status_test_LDFLAGS = -Wl,--hash-style=gnu -no-install
+
diff --git a/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild b/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild
new file mode 100644
index 0000000..eb37abd
--- /dev/null
+++ b/dev-libs/redis-ipc/redis-ipc-0.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/VCTLabs/redis-ipc"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/VCTLabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ IUSE="static"
+fi
+
+DESCRIPTION="A wrapper library for using redis server and JSON as IPC mechanism"
+HOMEPAGE="https://github.com/VCTLabs/redis-ipc"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="virtual/pkgconfig
+ dev-db/hiredis
+ dev-libs/json-c"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-qa-warning.patch"
+
+ export ac_cv_prog_STRIP="$(type -P true ) faking strip"
+
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE=${S} \
+ STRIP=/bin/true \
+ econf \
+ $(use_enable static) \
+ "${myconf[@]}"
+}