aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2017-11-15 18:17:03 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2017-11-15 18:17:03 +0400
commit366b8cc77dc32ef44909748af4f00b3d8067992f (patch)
tree5901664117d53a23c8aa5757731ef223790c9e12 /dev-lang
parentMerge pull request #351 from ArsenShnurkov/CastleDynamicProxy (diff)
downloaddotnet-366b8cc77dc32ef44909748af4f00b3d8067992f.tar.gz
dotnet-366b8cc77dc32ef44909748af4f00b3d8067992f.tar.bz2
dotnet-366b8cc77dc32ef44909748af4f00b3d8067992f.zip
mono 5.8.0.22 (experimental stuff)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-5.8.0.22.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 13deb59..a321678 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -2,3 +2,4 @@ DIST mono-5.0.1.1.tar.bz2 154477308 SHA256 48d6ae71d593cd01bf0f499de569359d45856
DIST mono-5.2.0.196.tar.bz2 158175736 SHA256 731634b24c89680660fed1efd63a39ec6c052e519ae9a2dce61f875598329366 SHA512 9a767d3fa30ef2d96cce13767c5da5604443495071da475a1f1452916501f2b6a94c2a45dfeee49cc0423cfeee48640a28989ea5d61270fbd51cadd143dc425c WHIRLPOOL 85841722c311d5eb976213a18a771930bd67994706007f1ffa536c4380c877f2b7d422798f51a6567554eb93e81fff33477106bba534881fcd985076f8168fa6
DIST mono-5.2.0.224.tar.bz2 158434164 SHA256 03b8e463032bc425673dec844b35b4c669f5b99b0e45521195efb3741a9f5e94 SHA512 914ab11c892f6e59c1a89d92eb4b130a62ea606691820f9d9f48a2a68f7de3e593c233be071cd37ad5d817c5f5fda6892f89f1b0985fc44de97c1297300c706b WHIRLPOOL 3c16019246341dc1abcc98358bc977142ff35510c226a76d5069bce0cece4754c1f81ca176f1ad988aabebfd482a03b524267aa3136e0df144c703ba3bea6c6f
DIST mono-5.4.0.167.tar.bz2 199774651 SHA256 c2afe51b0fb074936a8e7eaee805c352f37cbf1093bb41c5345078f77d913ce0 SHA512 c55a0732baed323438491d3c5ac04446932ae85f5da3298d2123208aef493ae1531edfd12965886d45b3d09a7fa954482211bf6a3f0ac5ce9aa10694ec13fd48 WHIRLPOOL e8a47c43c61943f797dd58e25abc93ae4f46ed27434c64026818a734a1691c3b5ab2eeca4bbc36f1ae09c64e874fe78128b8bb8cadf1315015354f46a609c5b2
+DIST mono-5.8.0.22.tar.bz2 204076657 SHA256 2a2f98299dfff2d0ba0c5c48868f9a974456088fe0055b1c7a8c587f5301ccac SHA512 e920b87d47d5e9f22fccbdd48635278eb87446aea7cfeb2d75711308378cfd2d23689ae5100a8a671cff2044f1d3677d02c2a7dcc8ad7459fac84de7addb623e WHIRLPOOL 958d68836ed720d7a81ea43b791ab127b819f9622e5da5f81de504ad772eee8080bd1e1b3af107f52175056ac7da3afff8f0a330fdc202eaafbd316979768e8f
diff --git a/dev-lang/mono/mono-5.8.0.22.ebuild b/dev-lang/mono/mono-5.8.0.22.ebuild
new file mode 100644
index 0000000..2640c83
--- /dev/null
+++ b/dev-lang/mono/mono-5.8.0.22.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ dev-util/cmake
+ !dev-lang/mono-basic
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1.1-x86_32.patch
+)
+
+#S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ if use kernel_linux; then
+ if linux_config_exists; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ #TODO: resolve problem with newer binutils
+ #bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
+ #append-flags -fPIC
+
+ default
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+multilib_src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}