aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@binghamton.edu>2016-05-07 17:22:40 -0400
committerBrian Dolbec <dolsen@gentoo.org>2016-05-07 19:06:37 -0700
commit230fe43ff6691ed3c092b6284ae2a8609cef0860 (patch)
tree97ed6278541cfaf3963c120a0762db29a8a7824b
parentxml-test/singularity: tests for at-most-one element violations (diff)
downloadgen-b0rk-230fe43ff6691ed3c092b6284ae2a8609cef0860.tar.gz
gen-b0rk-230fe43ff6691ed3c092b6284ae2a8609cef0860.tar.bz2
gen-b0rk-230fe43ff6691ed3c092b6284ae2a8609cef0860.zip
xml-test/uniqueness: tests for unique (element,attribute,value) combinations
Signed-off-by: Göktürk Yüksek <gokturk@binghamton.edu>
-rw-r--r--xml-test/uniqueness/metadata.xml33
-rw-r--r--xml-test/uniqueness/uniqueness-0.1.ebuild12
2 files changed, 45 insertions, 0 deletions
diff --git a/xml-test/uniqueness/metadata.xml b/xml-test/uniqueness/metadata.xml
new file mode 100644
index 0000000..84b3a1b
--- /dev/null
+++ b/xml-test/uniqueness/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Tests for the uniqueness of elements.
+
+ Uniqueness focuses on element, attribute, value combinations
+ which must not repeat.
+
+ The tests are conservative: i.e. if we check the
+ (longdescription, lang, restrict) combination, we do not check
+ (slots,lang, restrict).
+ </longdescription>
+ <!-- non-unique (longdescription, lang, restrict) combination -->
+ <longdescription lang='en'>uniqueness violation</longdescription>
+ <maintainer type='person'>
+ <email>gen-b0rk@gentoo.org</email>
+ </maintainer>
+ <maintainer type='project'>
+ <!-- non-unique (maintainer, email, restrict) combination -->
+ <email>gen-b0rk@gentoo.org</email>
+ </maintainer>
+ <slots>
+ <slot name="0">Match the SONAME of libuniqueness.so</slot>
+ <!-- non-unique (slot, name, restrict) combination -->
+ <slot name="0">uniqueness violation</slot>
+ </slots>
+ <use>
+ <flag name="foo">Enable feature foo</flag>
+ <!-- non-unique (flag, name, restrict) combination -->
+ <flag name="foo">uniqueness violation</flag>
+ </use>
+</pkgmetadata>
diff --git a/xml-test/uniqueness/uniqueness-0.1.ebuild b/xml-test/uniqueness/uniqueness-0.1.ebuild
new file mode 100644
index 0000000..03c3fa7
--- /dev/null
+++ b/xml-test/uniqueness/uniqueness-0.1.ebuild
@@ -0,0 +1,12 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Tests for (element, attribute, value) uniqueness"
+HOMEPAGE="https://wiki.gentoo.org/wiki/GLEP:68"
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="foo"