aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-04-05 17:42:48 -0400
committerJulien Roy <julien@jroy.ca>2024-04-05 17:57:11 -0400
commit3603f1f49eeda9b2d0b33e62d91128dbeb7d02b1 (patch)
tree4128fe4ffec0641ee557bc98b04fc6f6822e58d5
parentdev-db/pg_query_vala: new package, add 0.1.0_pre20240326 (diff)
downloadguru-3603f1f49eeda9b2d0b33e62d91128dbeb7d02b1.tar.gz
guru-3603f1f49eeda9b2d0b33e62d91128dbeb7d02b1.tar.bz2
guru-3603f1f49eeda9b2d0b33e62d91128dbeb7d02b1.zip
dev-db/psequel: new package, add 0.1.8
Signed-off-by: Julien Roy <julien@jroy.ca>
-rw-r--r--dev-db/psequel/Manifest1
-rw-r--r--dev-db/psequel/metadata.xml31
-rw-r--r--dev-db/psequel/psequel-0.1.8.ebuild47
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-db/psequel/Manifest b/dev-db/psequel/Manifest
new file mode 100644
index 000000000..1c49a4a57
--- /dev/null
+++ b/dev-db/psequel/Manifest
@@ -0,0 +1 @@
+DIST psequel-0.1.8.gh.tar.gz 1750537 BLAKE2B 6d170ea3b1cdfc441959cd536a69c12cff38234bc54db5c8e1b487837cb718a1a4370d73812160575effe7e231e8c1c066d9462370abc4b6363b133fb8fb072a SHA512 b4785c282bf9b10fc8d67620b81a89c9e673ac0fc12df2ba6f3fd33184bfccf800cb9bfee26ae876cade14c50b612c6c82d672dd564625db05f52743ae91bdfb
diff --git a/dev-db/psequel/metadata.xml b/dev-db/psequel/metadata.xml
new file mode 100644
index 000000000..1823388b3
--- /dev/null
+++ b/dev-db/psequel/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <name>Julien Roy</name>
+ <email>julien@jroy.ca</email>
+ </maintainer>
+ <longdescription>
+Small tool for quick sql query, specialized in PostgresSQL. Written in Vala for GNOME desktop in the hope to be useful.
+
+FeaturesL
+Load and save connections.
+Import and Export connections info
+List schema info, tables, views.
+View table columns info, indexes, foreign keys
+View table data, sort by column
+Write query
+Query History
+Hightlight current query
+Export query data
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <name>Pham Văn Phúc</name>
+ <email>phuclaplace@gmail.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/ppvan/psequel/issues</bugs-to>
+ <changelog>https://github.com/ppvan/psequel/releases</changelog>
+ <remote-id type="github">ppvan/psequel</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/psequel/psequel-0.1.8.ebuild b/dev-db/psequel/psequel-0.1.8.ebuild
new file mode 100644
index 000000000..57ba860f0
--- /dev/null
+++ b/dev-db/psequel/psequel-0.1.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson gnome2-utils vala xdg
+
+DESCRIPTION="Run your SQL query"
+HOMEPAGE="https://github.com/ppvan/psequel"
+SRC_URI="https://github.com/ppvan/psequel/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-db/postgresql
+ gui-libs/gtk:4
+ gui-libs/libadwaita:1
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lang/vala-0.56
+ >=gui-libs/gtk-4.10.0:4
+ >=gui-libs/gtksourceview-5.0:5
+ >=dev-libs/glib-2.74.0:2
+ >=dev-libs/json-glib-1.6.0
+ >=gui-libs/libadwaita-1.0:1
+ >=dev-db/postgresql-15.3
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}