aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-06 13:38:39 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-02-06 13:43:05 +0500
commit3a82871fb73d64fef2455ac16dcf522b419009e2 (patch)
treea4a25d387aa3cd89e9579b0e92b3834ec6154843
parentapp-accessibility/rhvoice-core: update DESCRIPTION (diff)
downloadguru-3a82871fb73d64fef2455ac16dcf522b419009e2.tar.gz
guru-3a82871fb73d64fef2455ac16dcf522b419009e2.tar.bz2
guru-3a82871fb73d64fef2455ac16dcf522b419009e2.zip
app-accessibility/rhvoice: add 1.14.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--app-accessibility/rhvoice/metadata.xml44
-rw-r--r--app-accessibility/rhvoice/rhvoice-1.14.0.ebuild35
2 files changed, 57 insertions, 22 deletions
diff --git a/app-accessibility/rhvoice/metadata.xml b/app-accessibility/rhvoice/metadata.xml
index 596997d70..acac05e05 100644
--- a/app-accessibility/rhvoice/metadata.xml
+++ b/app-accessibility/rhvoice/metadata.xml
@@ -1,29 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<upstream>
- <remote-id type="github">RHVoice/RHVoice</remote-id>
-</upstream>
<!-- maintainer-needed -->
-<use>
- <flag name="cli">Build a CLI application that allows you to synthesize speech</flag>
- <flag name="server">Build a server application</flag>
- <flag name="speech-dispatcher">Build a speech-dispatcher middleware module</flag>
- <!-- flag name="utils">Build utilities needed for the ones creating voices</flag -->
-</use>
-<longdescription lang="en">
- RHVoice is a free and open source speech synthesizer.
+ <upstream>
+ <remote-id type="github">RHVoice/RHVoice</remote-id>
+ </upstream>
+ <use>
+ <flag name="cli" restrict="&lt;app-accessibility/rhvoice-1.14">Build a CLI application that allows you to synthesize speech</flag>
+ <flag name="redistributable" restrict="&gt;=app-accessibility/rhvoice-1.14">Install also non-free (but redistributable) voices</flag>
+ <flag name="server" restrict="&lt;app-accessibility/rhvoice-1.14">Build a server application</flag>
+ <flag name="speech-dispatcher" restrict="&lt;app-accessibility/rhvoice-1.14">Build a speech-dispatcher middleware module</flag>
+ </use>
+ <longdescription lang="en">
+ RHVoice is a free and open source speech synthesizer.
- Voices are built from recordings of natural speech. They have small
- footprints, because only statistical models are stored on users'
- computers. And though the voices lack the naturalness of the
- synthesizers which generate speech by combining segments of the
- recordings themselves, they are still very intelligible and resemble
- the speakers who recorded the source material.
+ Voices are built from recordings of natural speech. They have small
+ footprints, because only statistical models are stored on users'
+ computers. And though the voices lack the naturalness of the
+ synthesizers which generate speech by combining segments of the
+ recordings themselves, they are still very intelligible and resemble
+ the speakers who recorded the source material.
- Initially, RHVoice could speak only Russian. Now it also supports
- American English, Brazilian Portuguese, Esperanto, Georgian, Ukrainian,
- Kyrgyz and Tatar. In theory, it is possible to implement support for
- other languages, if all the necessary resources can be found or created.
-</longdescription>
+ Initially, RHVoice could speak only Russian. Now it also supports
+ American English, Brazilian Portuguese, Esperanto, Georgian, Ukrainian,
+ Kyrgyz and Tatar. In theory, it is possible to implement support for
+ other languages, if all the necessary resources can be found or created.
+ </longdescription>
</pkgmetadata>
diff --git a/app-accessibility/rhvoice/rhvoice-1.14.0.ebuild b/app-accessibility/rhvoice/rhvoice-1.14.0.ebuild
new file mode 100644
index 000000000..5aeed05b5
--- /dev/null
+++ b/app-accessibility/rhvoice/rhvoice-1.14.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+declare -A VOICES=(
+ [en]="
+ redistributable? (
+ app-voices/rhvoice-bdl
+ app-voices/rhvoice-clb
+ app-voices/rhvoice-slt
+ )
+ "
+ [ru]="redistributable? ( app-voices/rhvoice-arina )"
+)
+
+DESCRIPTION="TTS engine with extended languages support (metapackage)"
+HOMEPAGE="
+ https://rhvoice.org
+ https://github.com/RHVoice/RHVoice
+"
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="redistributable"
+
+for lang in "${!VOICES[@]}"; do
+ usestr="l10n_${lang:?}"
+ IUSE+=" ${usestr:?}"
+ RHVOICE_REQ_USE+="${usestr:?}?,"
+ RDEPEND+=" ${usestr}? ( ${VOICES[${lang:?}]} )"
+done
+
+RDEPEND+=" >=app-accessibility/rhvoice-core-${PV}[${RHVOICE_REQ_USE%,}]"