aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Clarke <tomclarke2006@hotmail.com>2024-07-12 15:22:10 +0100
committerThomas Clarke <tomclarke2006@hotmail.com>2024-07-12 15:22:10 +0100
commit643e4ea972aa758c2e9ebef0102a8b8154f78be8 (patch)
tree03a147a52b6e5291f56f5c336c7ed24f2d67a6dc
parentx11-misc/i3status-rust: remove unexpected Result<T,E> handling in patch (diff)
downloadguru-643e4ea972aa758c2e9ebef0102a8b8154f78be8.tar.gz
guru-643e4ea972aa758c2e9ebef0102a8b8154f78be8.tar.bz2
guru-643e4ea972aa758c2e9ebef0102a8b8154f78be8.zip
net-im/whatsapp-for-linux: add 1.6.4
Signed-off-by: Thomas Clarke <tomclarke2006@hotmail.com>
-rw-r--r--net-im/whatsapp-for-linux/Manifest1
-rw-r--r--net-im/whatsapp-for-linux/metadata.xml5
-rw-r--r--net-im/whatsapp-for-linux/whatsapp-for-linux-1.6.4.ebuild47
3 files changed, 52 insertions, 1 deletions
diff --git a/net-im/whatsapp-for-linux/Manifest b/net-im/whatsapp-for-linux/Manifest
index 190ec29b46..024a5d5277 100644
--- a/net-im/whatsapp-for-linux/Manifest
+++ b/net-im/whatsapp-for-linux/Manifest
@@ -1,2 +1,3 @@
DIST whatsapp-for-linux-1.5.3.tar.gz 352927 BLAKE2B 0af7dde3840b2d42c92256e0edd3fcfc461e3dc818d2330088c603bbcf99cd095e81b78068d579b21fcc1a458eebe325c492f6d036136b96812205f94a6f2cad SHA512 7ef6b0135668b90f256a07c4d273d2732e79213be81bb6b0ee819107211e603a8d0b7fc7aaca6e7746de650f831955f4f560891f1bc2d5acdb0210bad79d91e9
DIST whatsapp-for-linux-1.6.2.tar.gz 354926 BLAKE2B c70c1ae9b6c8f74f801a52c4b95d0548c14368e874148cde8a028e3e55fc824fe17b527fd724b05bd5302abb762cad241a0d4321b5527bd3d6d35e544572fe32 SHA512 3ff54d202975a91177f5803312f09a71c23c39447063efa8c5e8e10eeea69f83e8e5397edeb7be1bcba5433ed0733b69728bfeeb5eaccbe7d605be362952d056
+DIST whatsapp-for-linux-1.6.4.tar.gz 361480 BLAKE2B a7daab0336c82eabb8c1dc3bf01888873dbea4389343af852f0f9dc0e7d8e1d0fc0f742464d8135a68a29e51a83b265e0bb334ac9bac26414c88c98ee85cca5a SHA512 d9da95684efbe6239d6a476808220a38c3df3a3096496342348934f745b0f6f53a7d723e27ce52ec746518e6f76880dcd52e433aee78ff566cd8fac6083ef395
diff --git a/net-im/whatsapp-for-linux/metadata.xml b/net-im/whatsapp-for-linux/metadata.xml
index ebc9371153..6ec15165d5 100644
--- a/net-im/whatsapp-for-linux/metadata.xml
+++ b/net-im/whatsapp-for-linux/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>tomclarke2006@hotmail.com</email>
+ <name>Thomas Clarke</name>
+ </maintainer>
<upstream>
<remote-id type="github">eneshecan/whatsapp-for-linux</remote-id>
<bugs-to>https://github.com/eneshecan/whatsapp-for-linux/issues</bugs-to>
diff --git a/net-im/whatsapp-for-linux/whatsapp-for-linux-1.6.4.ebuild b/net-im/whatsapp-for-linux/whatsapp-for-linux-1.6.4.ebuild
new file mode 100644
index 0000000000..fc2258fca1
--- /dev/null
+++ b/net-im/whatsapp-for-linux/whatsapp-for-linux-1.6.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="An unofficial WhatsApp desktop application for Linux"
+HOMEPAGE="https://github.com/eneshecan/whatsapp-for-linux"
+SRC_URI="https://github.com/eneshecan/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+LANGUAGES="en es it ka nl pt-BR ru tr"
+for lang in ${LANGUAGES}; do
+ IUSE+=" +l10n_${lang}"
+done
+
+RDEPEND="
+ dev-cpp/atkmm
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib
+ dev-libs/libayatana-appindicator
+ dev-libs/libsigc++:2
+ media-libs/libcanberra
+ || (
+ net-libs/webkit-gtk:4
+ net-libs/webkit-gtk:4.1
+ )
+ x11-libs/gtk+:3
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-util/intltool"
+
+src_prepare() {
+ cmake_src_prepare
+ for lang in ${LANGUAGES}; do
+ if ! use l10n_${lang}; then
+ rm "${S}/po/${lang,,}.po" || die "Failed to remove localization"
+ sed -i -e "/${lang,,}/d" "${S}/po/LINGUAS" || die
+ fi
+ done
+}