aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDale Showers <gentoo@fictx.com>2024-08-01 19:00:44 -0400
committerDale Showers <gentoo@fictx.com>2024-08-01 19:01:35 -0400
commitabab298880f704b09ae7fa44ff24d3c1e8a3205d (patch)
tree236af6c1e75b028133b0055759282565b125b75f
parentnet-im/whatsapp-for-linux: fix bug 936919 (diff)
downloadguru-abab298880f704b09ae7fa44ff24d3c1e8a3205d.tar.gz
guru-abab298880f704b09ae7fa44ff24d3c1e8a3205d.tar.bz2
guru-abab298880f704b09ae7fa44ff24d3c1e8a3205d.zip
www-client/nyxt: add v3.11.8
Signed-off-by: Dale Showers <gentoo@fictx.com>
-rw-r--r--www-client/nyxt/Manifest1
-rw-r--r--www-client/nyxt/nyxt-3.11.8.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/www-client/nyxt/Manifest b/www-client/nyxt/Manifest
index 1689bb25b..9f01896b1 100644
--- a/www-client/nyxt/Manifest
+++ b/www-client/nyxt/Manifest
@@ -2,3 +2,4 @@ DIST nyxt-3.11.4.gh.tar.xz 18095472 BLAKE2B 04aa9378efbf23153044c8e64f303240a9c4
DIST nyxt-3.11.5.gh.tar.xz 18100684 BLAKE2B 190ca6087cd781253bb08818072122bd720b423981621b5c94eb525816893ac9438bf278068378a60f3514b806f4681f697d7ff2061e2b71daf00b722c33b5c4 SHA512 1991c4c16e45df08b0630f003ca52213697a569e7545e412ede0a72af67337076c0e2605f4d85388717505513438bfcc2401db8a49c0d5a3c6e734669ac56661
DIST nyxt-3.11.6.gh.tar.xz 18092664 BLAKE2B ec540c4d751cb3d85df3c39fac6b48cb4355975c43f14391565fc72ec3aba9281001919251cb3d62800ac58501f33193ce96eedc720a6b41b2a5d4257c323202 SHA512 29aece8bf7c5d0ac47ab33e3f3387da7e62d669be1f2b7d08b27897982dcf07470c9d0cc59c58eee3bb174429d0f08226e51735162b87b37a2cf69148ec45f26
DIST nyxt-3.11.7.gh.tar.xz 18094656 BLAKE2B 6e7dbe65601525fafa493cc86689062a3157812f8d7991bee42926291efeaddb699596d6eaa7207c633ec2e6beb3cd32884ba1ab0990aafeace8080b5cb242c1 SHA512 853cb4ec7fe0e04a9f4672170965d6e71c9c81d77382b08f3abe8bb68ce6d44b6ba2a8c3ed6d7d47b2a0a6a92cc3c312189ea7a0635f1a7a3c1ebcea8f710a40
+DIST nyxt-3.11.8.gh.tar.xz 18101916 BLAKE2B b90d7967367ce0628e1451a04cab1fde3608a8f2137d5907a1247379a711e19168b2b7d04852f831a5f0ecb5680a79b4a31a235b7002ffd4de4dc99f8c70f2b7 SHA512 f6b1fcbb4bc4436cc39b0766f7a6a4e57cee81b785e04b1897c04836c6f349a8b5149118869fe36c8cc4c89518c88df75a47118f422149149f25b606a192cdf2
diff --git a/www-client/nyxt/nyxt-3.11.8.ebuild b/www-client/nyxt/nyxt-3.11.8.ebuild
new file mode 100644
index 000000000..ca8d78a87
--- /dev/null
+++ b/www-client/nyxt/nyxt-3.11.8.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature xdg
+
+DESCRIPTION="Nyxt - the hacker's power-browser"
+HOMEPAGE="https://nyxt.atlas.engineer/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atlas-engineer/${PN}.git"
+ EGIT_SUBMODULES=( '*' )
+ EGIT_BRANCH="master"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/atlas-engineer/${PN}/releases/download/${PV}/nyxt-${PV}-source-with-submodules.tar.xz -> ${PF}.gh.tar.xz"
+fi
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+IUSE="doc"
+
+# Portage replaces the nyxt binary with sbcl when stripping
+RESTRICT="mirror strip"
+
+RDEPEND="
+ dev-libs/gobject-introspection
+ gnome-base/gsettings-desktop-schemas
+ net-libs/glib-networking
+ net-libs/webkit-gtk:4.1
+ sys-libs/libfixposix
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-lisp/sbcl-2.0.0[threads,unicode]
+"
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+if [[ "${PV}" != 9999 ]]; then
+ src_unpack() {
+ mkdir "${WORKDIR}/${P}" || die
+ cd "${WORKDIR}/${P}"
+ default
+}
+
+fi
+
+src_compile() {
+ emake all
+ use doc && emake doc
+}
+
+src_install(){
+ dobin "${S}/nyxt"
+
+ if [ "$(use doc)" ]
+ then
+ docinto "/usr/share/doc/${P}"
+ dodoc "${S}/manual.html"
+ fi
+
+ for icon in 16x16 32x32 128x128 256x256 512x512; do
+ newicon -s ${icon} "${S}/assets/nyxt_${icon}.png" ${PN}.png
+ done
+
+ domenu "${S}/assets/nyxt.desktop"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "for X11 clipboard support" "x11-misc/xclip"
+ optfeature "for spellchecking" "app-text/enchant"
+ optfeature "for HTML5 audio/video" "media-libs/gstreamer"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-bad"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-base"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-good"
+ optfeature "for HTML5 audio/video" "media-libs/gst-plugins-ugly"
+ optfeature "for HTML5 audio/video" "media-plugins/gst-plugins-libav"
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}