aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSkyler Mäntysaari <sm+git@skym.fi>2024-09-01 15:41:18 +0300
committerSkyler Mäntysaari <sm+git@skym.fi>2024-09-01 15:41:18 +0300
commit9b42f368f96de46bc5bd57f0f4d154cac4f93109 (patch)
tree508fcdbe81dc24e945e82ff8f6059f5a60e9dac6 /app-admin
parentdev-util/go-task: new package, add 3.38.0-r1 (diff)
downloadguru-9b42f368f96de46bc5bd57f0f4d154cac4f93109.tar.gz
guru-9b42f368f96de46bc5bd57f0f4d154cac4f93109.tar.bz2
guru-9b42f368f96de46bc5bd57f0f4d154cac4f93109.zip
app-admin/talosctl-bin: new package, add 1.7.6
Signed-off-by: Skyler Mäntysaari <sm+git@skym.fi>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/talosctl-bin/Manifest3
-rw-r--r--app-admin/talosctl-bin/metadata.xml8
-rw-r--r--app-admin/talosctl-bin/talosctl-bin-1.7.6.ebuild28
3 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/talosctl-bin/Manifest b/app-admin/talosctl-bin/Manifest
new file mode 100644
index 000000000..31e066ef9
--- /dev/null
+++ b/app-admin/talosctl-bin/Manifest
@@ -0,0 +1,3 @@
+DIST talosctl-amd64-v1.7.6 79237272 BLAKE2B fae6d5a3c00ad09c6f8509ec6f7bdf2005e278eb524d82ec5ad11a4896d53e3540e580edcfa854a290597399ed907ebeeb8b25d95c685fcaf5d3dcf4097845c7 SHA512 077195e8ec0bcd854c7bb1b3c895f1ec1d64d3e102188234e00911e1e205933276dbafcffd0b04e3fd667cc76d8a09422e379a6d92da41d266264dba1070261a
+DIST talosctl-arm64-v1.7.6 76808344 BLAKE2B c89b4517cdcf511c153e1fa8f20883969b9b58f5fbaa97090af7215782a3943e7f765ae806f3e9e2ca8bab11152afb5a8e8493bfc11eb851d9008f25f3917d64 SHA512 845f69b8ff8508885d0494523280b6d025809abf6cacc923fd5c1049a156e6185a36462d2f4fe67d7699f20f78c00b8b5bc469a4d0c03a00b61ccf7e660608d2
+DIST talosctl-armv7-v1.7.6 75301016 BLAKE2B 03fec115f7cce619d39f625057e5256fe9ae72775094b5b9ae32393c7ecfe39c03bad81e51628a948f1e40912c0937b35ab329748c63341062813207cfc59dfa SHA512 868ffd828f6eae6c964cc4b4f7f8ea73772df5e1bcd6f524b53e81779bce45b950aabcc180c842d87c242d3b382d82a5b2ee9d918f897b47dfdf50cf0dec4b56
diff --git a/app-admin/talosctl-bin/metadata.xml b/app-admin/talosctl-bin/metadata.xml
new file mode 100644
index 000000000..3b2e026d0
--- /dev/null
+++ b/app-admin/talosctl-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sm+gentoo@skym.fi</email>
+ <name>Skyler</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-admin/talosctl-bin/talosctl-bin-1.7.6.ebuild b/app-admin/talosctl-bin/talosctl-bin-1.7.6.ebuild
new file mode 100644
index 000000000..1de0efe9e
--- /dev/null
+++ b/app-admin/talosctl-bin/talosctl-bin-1.7.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Pre-compiled talosctl is an tool for interacting with the Talos API"
+HOMEPAGE="https://www.talos.dev/v1.7/"
+SLOT="0"
+S="${WORKDIR}"
+LICENSE="MPL2.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+SRC_URI="
+ amd64? ( https://github.com/siderolabs/talos/releases/download/v${PV}/talosctl-linux-amd64 -> talosctl-amd64-v${PV} )
+ arm64? ( https://github.com/siderolabs/talos/releases/download/v${PV}/talosctl-linux-arm64 -> talosctl-arm64-v${PV} )
+ arm? ( https://github.com/siderolabs/talos/releases/download/v${PV}/talosctl-linux-armv7 -> talosctl-armv7-v${PV} )
+"
+
+src_install() {
+ if use arm; then
+ newbin "${DISTDIR}"/talosctl-armv7-v${PV} talosctl
+ fi
+ if use arm64; then
+ newbin "${DISTDIR}"/talosctl-arm64-v${PV} talosctl
+ fi
+ if use amd64; then
+ newbin "${DISTDIR}"/talosctl-amd64-v${PV} talosctl
+ fi
+}