aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Burnham <danipo@gmail.com>2023-07-22 00:34:09 -0400
committerSteven Burnham <danipo@gmail.com>2023-07-22 00:34:42 -0400
commit62751a63881e36b8d5fbdbf835d8dfac0af5dbb6 (patch)
tree8a2b45f2d8c779f73a668b6f140bc7ecc69c22dc /app-emulation
parentwww-apps/code-server-bin: add 4.15.0 (diff)
downloadguru-62751a63881e36b8d5fbdbf835d8dfac0af5dbb6.tar.gz
guru-62751a63881e36b8d5fbdbf835d8dfac0af5dbb6.tar.bz2
guru-62751a63881e36b8d5fbdbf835d8dfac0af5dbb6.zip
app-emulation/quickemu: add 4.8
Signed-off-by: Steven Burnham <danipo@gmail.com>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/quickemu/Manifest1
-rw-r--r--app-emulation/quickemu/quickemu-4.8.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/quickemu/Manifest b/app-emulation/quickemu/Manifest
index 90817dda9..633ddc4a7 100644
--- a/app-emulation/quickemu/Manifest
+++ b/app-emulation/quickemu/Manifest
@@ -1 +1,2 @@
DIST quickemu-3.11.tar.gz 128498 BLAKE2B 15791e21733a2b77b54e8b25d37f9f8b7a112e249635c187ba1267f2bea089f38d96e5690da2d44b82b3668827df524afa765b42f90f61bfe368f53c773c51b4 SHA512 076c6e4108c5bb0e85e36c13da91e3c7f3f607b54cd50cbf73cc64fc157198a18daaa7131473e5d6166e1babd905645b673d05373a2f18959bdb4a8a1c9f897f
+DIST quickemu-4.8.tar.gz 166544 BLAKE2B 527ce0cb7310d4d4f3ce19900a60b40b1534a637c58899beb48a947b4bd29c02c8381af65b966f205883c811219cadd2c6dcb40d5bb6925ed92db4283b7d1d4c SHA512 1f09e99ac4e508d5fe9e26482bd6b318f4cc0256bb8079799dc162ea5789ca99a07a11af283456f7832eed0c970ec0dae46e3ab2e80696954f16ff6807e32765
diff --git a/app-emulation/quickemu/quickemu-4.8.ebuild b/app-emulation/quickemu/quickemu-4.8.ebuild
new file mode 100644
index 000000000..b20d3412b
--- /dev/null
+++ b/app-emulation/quickemu/quickemu-4.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+inherit python-single-r1
+
+DESCRIPTION="Create and run optimised Windows, macOS and Linux desktop virtual machines"
+HOMEPAGE="https://github.com/quickemu-project/quickemu"
+SRC_URI="https://github.com/quickemu-project/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=app-emulation/qemu-6.0.0[gtk,sdl,spice]
+ >=app-shells/bash-4.0:=
+ app-cdr/cdrtools
+ app-crypt/swtpm
+ app-misc/jq
+ net-misc/spice-gtk[gtk3]
+ net-misc/wget
+ net-misc/zsync
+ sys-apps/usbutils
+ sys-apps/util-linux
+ sys-firmware/edk2-ovmf
+ sys-process/procps
+ x11-apps/xrandr
+ x11-misc/xdg-user-dirs
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ python_doscript macrecovery macrecovery
+ dobin quickemu
+ dobin quickget
+}