aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHayley Hughes <hayley@foxes.systems>2022-02-08 22:21:22 +1100
committerHayley Hughes <hayley@foxes.systems>2022-02-08 22:23:04 +1100
commit8c74f0911812dbbf74c0a8ea903e0910a137149a (patch)
treec81fe3eadc1bd0dff4d1c4456277fe44f71f0f1f /app-emulation
parentapp-misc/fastfetch: drop 0.569 (diff)
downloadguru-8c74f0911812dbbf74c0a8ea903e0910a137149a.tar.gz
guru-8c74f0911812dbbf74c0a8ea903e0910a137149a.tar.bz2
guru-8c74f0911812dbbf74c0a8ea903e0910a137149a.zip
app-emulation/unicorn: Remove ebuild
* Was added to gentoo repos * Moved app-emulation/unicorn to dev-util/unicorn Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hayley Hughes <hayley@foxes.systems>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/unicorn/Manifest1
-rw-r--r--app-emulation/unicorn/metadata.xml16
-rw-r--r--app-emulation/unicorn/unicorn-1.0.3.ebuild58
3 files changed, 0 insertions, 75 deletions
diff --git a/app-emulation/unicorn/Manifest b/app-emulation/unicorn/Manifest
deleted file mode 100644
index fadbfcb1d..000000000
--- a/app-emulation/unicorn/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST unicorn-1.0.3.tar.gz 3759365 BLAKE2B 130d494d03aa9aa1b27e6806856eb36c1871af6e8b89aef9136baa6ca8b726ba2eab778488185e96c47bf3771dd8bce19bf4fd5090888d28433a6129c827d88c SHA512 10f1b5194358c65bc94723eaafd7b4167fee18f96a4810f46f8c78ed1ef5584546e66e8c910fa4eeadd791fcd73edea68f898e337081409fd188b4090b78a7ca
diff --git a/app-emulation/unicorn/metadata.xml b/app-emulation/unicorn/metadata.xml
deleted file mode 100644
index c9de728ed..000000000
--- a/app-emulation/unicorn/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>hayley@foxes.systems</email>
- <name>Hayley Hughes</name>
- </maintainer>
- <longdescription lang="en">
- Unicorn is a lightweight multi-platform, multi-architecture CPU emulator
- framework. Unicorn is based on QEMU, but it goes much further with a lot
- more to offer.
- </longdescription>
- <use>
- <flag name="python">Enable python bindings</flag>
- </use>
-</pkgmetadata>
diff --git a/app-emulation/unicorn/unicorn-1.0.3.ebuild b/app-emulation/unicorn/unicorn-1.0.3.ebuild
deleted file mode 100644
index da1b0f660..000000000
--- a/app-emulation/unicorn/unicorn-1.0.3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake distutils-r1
-
-DESCRIPTION="Unicorn CPU emulator framework"
-HOMEPAGE="http://www.unicorn-engine.org/"
-SRC_URI="https://github.com/unicorn-engine/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="test python"
-RESTRICT="!test? ( test )"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- python? ( dev-python/setuptools[${PYTHON_USEDEP}] )
-"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-wrap_python() {
- local phase=$1
- shift
-
- if use python; then
- pushd bindings/python >/dev/null || die
- echo distutils-r1_${phase} "$@"
- pwd
- distutils-r1_${phase} "$@"
- popd >/dev/null
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
- wrap_python ${FUNCNAME}
-}
-
-src_configure() {
- cmake_src_configure
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
- wrap_python ${FUNCNAME}
-}